<br><tt><font size=2>&gt; We have the RAC up with a single nic for the
public interface, the <br>
&gt; private interconnect and the ISCSI connection to the array.&nbsp;
The MTU<br>
&gt; on all these nics is 1500.</font></tt>
<br>
<br><tt><font size=2>Note: you must set the MTU for iSCSI connection to
9000 as well. &nbsp;If you don't, I wouldn't expect the host to accept
jumbo frames.</font></tt>
<br><tt><font size=2><br>
&gt; We want to bond one of the Broadcom nics and one of the Intel nics
<br>
&gt; for the public interface using an MTU of 1500. </font></tt>
<br><tt><font size=2>&gt; <br>
&gt; We want to bond the other Broadcom nic with an Intel nic and use it
<br>
&gt; for the RAC interconnect using an MTU of 9000. </font></tt>
<br>
<br><tt><font size=2>This is no problem at all - just apply the MTU setting
to the bond device (ifconfig bond0 mtu 9000)</font></tt>
<br>
<br><tt><font size=2>&gt; We want to bond the other 2 Intel nics and use
them to connect to <br>
&gt; the NX1950 using ISCSI with an MTU of 9000.&nbsp; &nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;
&nbsp;</font></tt>
<br>
<br><tt><font size=2>Again, just set the MTU on the bond device (ifconfig
bond1 mtu 9000)</font></tt>
<br>
<br><tt><font size=2>&gt; So, is there a bonding mode that can be used
for the public <br>
&gt; interface that does not require switch configuration?</font></tt>
<br>
<br><tt><font size=2>mode 0 - (balance-rr), 5 (adaptive-tlb), and 6 (balance-tlb)
do not require any special switch configuration.</font></tt>
<br>
<br><tt><font size=2>&gt; Is there a bonding mode compatible with the Dell
switch that we do <br>
&gt; control for the interconnect?&nbsp; I am trying to learn the switch
as I <br>
&gt; go and it seems that it supports 802.ad.&nbsp; Is there a bonding
mode <br>
&gt; that goes with that?</font></tt>
<br>
<br><tt><font size=2>Be sure to set the MTU on the 6248 to 9000 as well
(Switching-&gt;Ports-&gt;Port Configuration-&gt; Maximum Frame Size).</font></tt>
<br>
<br><tt><font size=2>It looks like your switch also supports LACP Link
aggregation (802.3ad). &nbsp;To make this work, configure your bond with
mode 4 and add the ports in the switch to a LAG group.</font></tt>
<br>
<br><tt><font size=2>&gt; Also, we tried setting the MTU to 9000 on the
RAC interconnect and <br>
&gt; one node started but the other two would not come up.&nbsp; Sorry
for no <br>
&gt; more information but I don&#8217;t have an error code at this time, but
<br>
&gt; does anyone have advice for me about this?</font></tt>
<br>
<br><tt><font size=2>The only advice I can offer is that you must have
the mtu set the same between the two hosts, plus enable jumbo frames on
your switch.</font></tt>
<br>
<br><tt><font size=2>&gt; Finally, does anyone have suggestions for testing
these connections <br>
&gt; once we have the bonding set up?</font></tt>
<br>
<br><tt><font size=2>iperf is a great tool to measure interface bandwidth
(</font></tt><a href=http://sourceforge.net/projects/iperf><tt><font size=2>http://sourceforge.net/projects/iperf</font></tt></a><tt><font size=2>).
&nbsp;iftop is also a great way to monitor the bond once you've got traffic
moving between the box and the switch.</font></tt>
<br>
<br><tt><font size=2>Hope this helps,<br>
Justin</font></tt>
<br>