<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
<html>
<head>
  <meta content="text/html;charset=UTF-8" http-equiv="Content-Type">
</head>
<body bgcolor="#ffffff" text="#000000">
I have some more information about kernel version<br>
<br>
To be more precise: I/O writes are OK till 2.6.21. The problem appears
in 2.6.22. I compiled more than 20 kernels since a few weeks now.
Hopefully, the hardware is very fast except that I/O problem.<br>
<br>
debian-test:/usr/src# uname -a<br>
Linux debian-test.pr.univmed.fr 2.6.22.1 #1 SMP Mon Jun 2 12:03:44 CEST
2008 i686 GNU/Linux<br>
debian-test:/usr/src# dd if=/dev/zero of=/root/test.cdrom bs=10k
count=60000<br>
60000+0 enregistrements lus<br>
60000+0 enregistrements écrits<br>
614400000 octets (614 MB) copiés, 8,10601 seconde, 75,8 MB/s<br>
debian-test:/usr/src# time tar -xzf linux-2.6.24.tar.gz<br>
<br>
real    0m9.740s<br>
user    0m2.732s<br>
sys     0m1.520s<br>
debian-test:/usr/src# dmesg | grep -i write<br>
sd 4:1:0:0: [sdb] Write Protect is off<br>
sd 4:1:0:0: [sdb] Write cache: enabled, read cache: enabled, doesn't
support DPO or FUA<br>
sd 4:1:0:0: [sdb] Write Protect is off<br>
sd 4:1:0:0: [sdb] Write cache: enabled, read cache: enabled, doesn't
support DPO or FUA<br>
<br>
<br>
debian-test:~# uname -a<br>
Linux debian-test.pr.univmed.fr 2.6.21.7 #1 SMP Fri May 30 18:39:58
CEST 2008 i686 GNU/Linux<br>
debian-test:~# dd if=/dev/zero of=/root/test.cdrom bs=10k count=60000<br>
60000+0 enregistrements lus<br>
60000+0 enregistrements écrits<br>
614400000 octets (614 MB) copiés, 1,21061 seconde, 508 MB/s<br>
debian-test:~#<br>
debian-test:/usr/src# time tar -xzf linux-2.6.24.tar.gz<br>
<br>
real    0m2.602s<br>
user    0m2.544s<br>
sys     0m1.508s<br>
<br>
debian-test:~# dmesg | grep -i write<br>
sda: Write Protect is off<br>
SCSI device sda: write cache: enabled, read cache: enabled, doesn't
support DPO or FUA<br>
sda: Write Protect is off<br>
SCSI device sda: write cache: enabled, read cache: enabled, doesn't
support DPO or FUA<br>
I'm not sure now that the problem comes from that string. The string
has been changed/added recently<br>
<br>
<br>
<br>
Alessandro FAGLIA a écrit :
<blockquote cite="mid:483FC5FA.9000104@farmol.it" type="cite">
  <pre wrap="">-------- Original Message  --------
Subject: Re: SAS 6/iR write performance depends on kernel version, blade 
server m600
From: Dominique LALOT <a class="moz-txt-link-rfc2396E" href="mailto:dom.lalot@gmail.com">&lt;dom.lalot@gmail.com&gt;</a>
To: Alessandro FAGLIA <a class="moz-txt-link-rfc2396E" href="mailto:a.faglia@farmol.it">&lt;a.faglia@farmol.it&gt;</a>, <a class="moz-txt-link-abbreviated" href="mailto:linux-poweredge@dell.com">linux-poweredge@dell.com</a>
Date: Fri May 30 2008 10:34:05 GMT+0200 (ora legale Europa occidentale)
  </pre>
  <blockquote type="cite">
    <pre wrap="">Alessandro FAGLIA a écrit :
    </pre>
    <blockquote type="cite">
      <pre wrap="">-------- Original Message  --------
Subject: SAS 6/iR write performance depends on kernel version, blade 
server    m600
From: Dominique LALOT <a class="moz-txt-link-rfc2396E" href="mailto:dom.lalot@gmail.com">&lt;dom.lalot@gmail.com&gt;</a>
To: <a class="moz-txt-link-abbreviated" href="mailto:linux-poweredge@dell.com">linux-poweredge@dell.com</a>
Date: Mon May 19 2008 16:05:10 GMT+0200 (ora legale Europa occidentale)
      </pre>
      <blockquote type="cite">
        <pre wrap="">Hello,

That's quite a long time, I'm "playing" around a performance problem.

We just acquire some  new blades and  I discovered something strange 
affecting the new SAS 6 subsystem.

[...]

        </pre>
      </blockquote>
      <pre wrap="">Good morning Mr Lalot.

I'm a Linux-PE ML reader, and we are buying two new R300 server with 
SAS 6iR RAID controller. We'd like to use them in RAID1 configuration.

I read your thread named "SAS 6/iR write performance depends on 
kernel version, blade server m600". BTW, there are other threads in 
the lists say that Debian (any version) is not going to work on such 
controller. 
      </pre>
    </blockquote>
    <pre wrap="">We are all using linux, we should not say debian won't .. or redhat 
will.. What we like about debian is the packaging system and the very 
few packages installed at first which is perfect for servers.
Debian Etch is working prefectly on LSI sas 6. That's a kernel issue. 
Fortunatly all the "Dell supported distrib" are using a kernel &lt;2.6.18.
    </pre>
  </blockquote>
  <pre wrap=""><!---->
Now I understand. If I'm correct, we should simply compile a kernel 
version less than 2.6.18 and everything should be fine.

  </pre>
  <blockquote type="cite">
    <pre wrap="">I'm still looking at kernel patch to see why sas 6  LSI controller is 
working so bad in the last kernels. I'm sure now, that the last 
kernels are asking firware, and the default settings are bad.

What we can say, is that last Ubuntu server 8.04  behaves very badly 
with LSI sas 6 (2.6.24)
    </pre>
  </blockquote>
  <pre wrap=""><!---->
Thanks for your feedback.

--
Alessandro


_______________________________________________
Linux-PowerEdge mailing list
<a class="moz-txt-link-abbreviated" href="mailto:Linux-PowerEdge@dell.com">Linux-PowerEdge@dell.com</a>
<a class="moz-txt-link-freetext" href="http://lists.us.dell.com/mailman/listinfo/linux-poweredge">http://lists.us.dell.com/mailman/listinfo/linux-poweredge</a>
Please read the FAQ at <a class="moz-txt-link-freetext" href="http://lists.us.dell.com/faq">http://lists.us.dell.com/faq</a></pre>
</blockquote>
<br>
</body>
</html>