<br><font size=2 face="sans-serif">Well, this sounds about right and after
implementing it did the trick. Thanks! Problem/annoyance solved ;-)</font>
<br>
<br>
<br>
<br>
<table width=100%>
<tr valign=top>
<td width=40%><font size=1 face="sans-serif"><b>Frank Warnke &lt;frank@newspapersystems.com&gt;</b>
</font>
<br><font size=1 face="sans-serif">Sent by: linux-poweredge-bounces@dell.com</font>
<p><font size=1 face="sans-serif">04-01-2007 18:06</font>
<table border>
<tr valign=top>
<td bgcolor=white>
<div align=center><font size=1 face="sans-serif">Please respond to<br>
frank@newspapersystems.com</font></div></table>
<br>
<td width=59%>
<table width=100%>
<tr>
<td>
<div align=right><font size=1 face="sans-serif">To</font></div>
<td valign=top><font size=1 face="sans-serif">linux-poweredge@dell.com</font>
<tr>
<td>
<div align=right><font size=1 face="sans-serif">cc</font></div>
<td valign=top><font size=1 face="sans-serif">Ludse.Verhoeven@vopak.com</font>
<tr>
<td>
<div align=right><font size=1 face="sans-serif">Subject</font></div>
<td valign=top><font size=1 face="sans-serif">Re: PE2850 and DRAC 4/I virtual
CD ROM problems</font></table>
<br>
<table>
<tr valign=top>
<td>
<td></table>
<br></table>
<br>
<br>
<br><font size=2><tt>On Thu, 4 Jan 2007 09:59:39 +0100, Ludse Verhoeven
wrote:<br>
<br>
&gt; Hi list,<br>
&gt; <br>
&gt; I'm having problems with a DELL PE2850 system, running RHEL4. The<br>
&gt; system <br>
&gt; now and then randomly seems to lock. For this I've already found in<br>
&gt; some <br>
&gt; previous thread (with the same subject) a possible workaround: adding
<br>
&gt; 'hdf=ide-scsi' to the kernel statement in the /boot/grub/grub.conf.<br>
&gt; Not <br>
&gt; sure if this really is working (just added the option yesterday and
<br>
&gt; rebooted the server, so it's just too soon to tell), but already two
<br>
&gt; events caught my eye. The first one is a statement during startup<br>
&gt; which <br>
&gt; finds the &quot;ide-scsi&quot; being deprecated for cd-burning. Well,
I'm not<br>
&gt; using <br>
&gt; a cd-burner here, so that's not too worrying. Secondly I constantly<br>
&gt; see a <br>
&gt; new message appear on my console stating that the &quot;Device is
not<br>
&gt; ready. <br>
&gt; Make sure there is a disc in the drive.&quot;. This message must be<br>
&gt; generated <br>
&gt; by the newly added option, since I haven't seen it before, at least<br>
&gt; not in <br>
&gt; such a rapid way: once every few seconds. Does anybody have an idea<br>
&gt; how to <br>
&gt; stop these messages and/or what option I should use i.s.o. the <br>
&gt; &quot;hdf=ide-scsi&quot; option I found in the archives?<br>
&gt; <br>
&gt; Thanks in advance,<br>
&gt; &nbsp; &nbsp; &nbsp; &nbsp; Ludse Verhoeven<br>
<br>
I have been working around the &quot;Device is not ready. Make sure there
is<br>
a disc in the drive.&quot; message by using these instructions by Sean<br>
Plaice;<br>
<br>
Message: 1<br>
Date: Fri, 11 Nov 2005 04:38:20 -0800<br>
From: Sean Plaice<br>
Subject: DRAC/RHEL4 Annoyance solved - &quot;Device not ready. Make sure<br>
 &nbsp; &nbsp; &nbsp; &nbsp; there is a disc in the drive.&quot; repeated
in dmesg<br>
To: linux-poweredge@dell.com<br>
Message-ID:<br>
Content-Type: text/plain; charset=ISO-8859-1<br>
<br>
Hello,<br>
I am not sure if anyone has run into this annoyance, though since I<br>
could not find any notes of it on the net or this lists archives I<br>
thought I would post this.<br>
<br>
On my PE1850's with DRAC4's upon telling the kernel to treated the<br>
DRAC4 virtual cdrom to use ide scsi emulation (hd4=ide-scsi to kernel<br>
cmdline). I found that my systems would be flooded with &quot;Device not<br>
ready. &nbsp;Make sure there is a disc in the drive.&quot; messages.<br>
<br>
After a bit of troubleshooting I found the culprit to be hald. Redhat<br>
ships /etc/hal/hald.conf with configuration that will do a media check<br>
of all storage that hald detects by default. This check is what<br>
generated the errors by accessing the DRAC4 device (/dev/sr0, renamed<br>
to /dev/scd0 by udev). Telling hald to not perform the media check<br>
(which is not needed by my systems), prevents it from running the<br>
media check, and from generating the messages.<br>
<br>
You can tell hald to not perform the media check by updating the hald<br>
config file (/etc/hal/hald.conf).<br>
<br>
Enabled.<br>
&lt;storage_media_check_enabled&gt;true&lt;/storage_media_check_enabled&gt;<br>
<br>
Disabled.<br>
&lt;storage_media_check_enabled&gt;false&lt;/storage_media_check_enabled&gt;<br>
<br>
You could also modify hald's behavior using .fdi files. I have no<br>
examples of this since I do not need the media check at all.<br>
<br>
Please note that this will disable the media check for all storage<br>
devices that hald finds, this might be of concern for desktop users<br>
that want hald to check their media when inserting a cd to their cdrom<br>
etc.<br>
<br>
This might be something worth adding the DRAC4 installation notes, or<br>
documentation.<br>
<br>
Hope this helps, if this has been pointed out before and I just missed<br>
it, sorry for the noise.<br>
<br>
--<br>
Sean Plaice<br>
<br>
 &nbsp; After making the changes, restart Hal by typing;<br>
<br>
 &nbsp; &nbsp; &nbsp;service haldaemon restart<br>
<br>
_______________________________________________<br>
Linux-PowerEdge mailing list<br>
Linux-PowerEdge@dell.com<br>
http://lists.us.dell.com/mailman/listinfo/linux-poweredge<br>
Please read the FAQ at http://lists.us.dell.com/faq<br>
<br>
</tt></font>
<br>
<br>
<br>
<span style="font-family:'Arial',sans-serif; font-size:8pt; font-weight:bold; color:#000080">Ludse Verhoeven</span><br>
<span style="font-family:'Arial',sans-serif; font-size:8pt; color:#000080">AIX System Engineer<br>
T: +31 10 400 2440<br>
M: <br>
F: +31 10 400 2891<br>
E: Ludse.Verhoeven@VOPAK.COM</span><br>
<br>
<span style="font-family:'Arial',sans-serif; font-size:8pt; font-weight:bold; color:#000080">Vopak Information Services B.V.</span><br>
<span style="font-family:'Arial',sans-serif; font-size:8pt; color:#000080">Trade Register: 24146892<br>
Visit Address: Westerlaan 10, 3016 CK Rotterdam<br>
Postal Address: P.O. Box 863, 3000 AW  Rotterdam<br>
The Netherlands<br>
http://www.vopak.com</span><br>
<br>
<span style="font-family:'Arial',sans-serif; font-size:7pt; color:#000080">A Royal Vopak company</span>