<br><br>---------- Forwarded message ----------<br><span class="gmail_quote">From: <b class="gmail_sendername">Adrian Gajan</b> &lt;<a href="mailto:adrian.gajan@gmail.com">adrian.gajan@gmail.com</a>&gt;<br>Date: Dec 7, 2006 10:17 AM
<br>Subject: Re: Dell PE 1850 ipmi &amp; dell_rbu kernel module issue<br>To: Adrian Gajan &lt;<a href="mailto:adrian.gajan@gmail.com">adrian.gajan@gmail.com</a>&gt;, <a href="mailto:linux-poweredge@dell.com">linux-poweredge@dell.com
</a><br><br></span>Hi Matt,<br><br>i've only installed the rpms which are needed to take the neccesary actions (bios&amp;drac flash, set drac passwd, ip, gw and netmask) so I had not installed the whole OMSA software package. I've tryied to use the install script which is provided in the OMSA package, but this didnt work because of the OS recognition (we are using CentOS which is not support by Dell). Anyway, you mentioned, that ipmi has its own copy of initscript, could you please provide information where is it stored or how to remove this?
<br><br>One other question relating the dell_rbu kernel module:<br><br>there is no record of dell_rbu in /etc/modprobe.conf and the module is loading at the boot - &gt; same thing like ipmi?<br><br>Thanks a lot and have a nice day:)
<br><br>Adrian<div><span class="e" id="q_10f5c3451421b1ae_1"><span style="text-decoration: underline;"><span style="font-style: italic;"><span style="font-weight: bold;"></span></span></span><br><br><div><span class="gmail_quote">
On 12/7/06, <b class="gmail_sendername">
Matt Domsch</b> &lt;<a href="mailto:Matt_Domsch@dell.com" target="_blank" onclick="return top.js.OpenExtLink(window,event,this)">Matt_Domsch@dell.com</a>&gt; wrote:</span><blockquote class="gmail_quote" style="border-left: 1px solid rgb(204, 204, 204); margin: 0pt 0pt 0pt 0.8ex; padding-left: 1ex;">

On Wed, Dec 06, 2006 at 07:02:16PM +0100, Adrian Gajan wrote:<br>&gt;&nbsp;&nbsp;&nbsp;&nbsp;Hello,<br>&gt;<br>&gt;&nbsp;&nbsp;&nbsp;&nbsp;i've installed the necessary Dell software on a PE1850 in order to be able<br>&gt;&nbsp;&nbsp;&nbsp;&nbsp;to execute BIOS &amp; DRAC updates. I've wrote a bash script, which updates
<br>&gt;&nbsp;&nbsp;&nbsp;&nbsp;BIOS and DRAC firmware and sets the DRAC IP, mask, gw and password. After<br>&gt;&nbsp;&nbsp;&nbsp;&nbsp;this will the script remove the installed rpms, such as srvadmin-hapi,<br>&gt;&nbsp;&nbsp;&nbsp;&nbsp;srvadmin-ipmi etc... This is done without any problems, after this step
<br>&gt;&nbsp;&nbsp;&nbsp;&nbsp;there is a &quot;for i in $(find /etc -name *ipmi); do rm -rf $i; done&quot;<br>&gt;&nbsp;&nbsp;&nbsp;&nbsp;command, which removes the links and the starting ipmi shell script.<br>&gt;&nbsp;&nbsp;&nbsp;&nbsp;Anyway, after reboot the server is still trying to load the ipmi and
<br>&gt;&nbsp;&nbsp;&nbsp;&nbsp;dell_rbu drivers on boot.<br><br>any chance OMSA is installed?&nbsp;&nbsp;It has its own copy of the ipmi<br>initscript in case the system-provided copy isn't present.<br><br>--<br>Matt Domsch<br>Software Architect<br>
Dell Linux Solutions 
<a href="http://linux.dell.com" target="_blank" onclick="return top.js.OpenExtLink(window,event,this)">linux.dell.com</a> &amp; <a href="http://www.dell.com/linux" target="_blank" onclick="return top.js.OpenExtLink(window,event,this)">
www.dell.com/linux</a><br>Linux on Dell mailing lists @ <a href="http://lists.us.dell.com" target="_blank" onclick="return top.js.OpenExtLink(window,event,this)">http://lists.us.dell.com</a><br></blockquote>
</div><br><br clear="all"><br></span></div>-- <br>Rgds,<br><span class="sg">Adrian Gajan

</span><br clear="all"><br>-- <br>Rgds,<br>Adrian Gajan