[Linux-PowerEdge] Solved - R740xd - HBA330 - mpt3sas - 18.04.4

Timo Scheller t.scheller at its.uni-saarland.de
Wed Mar 25 03:46:39 CDT 2020


Good morning,

first many thx to the list for your help!
And second, many thx to the guys from Dell, reading this list too.

Therefore with the help of Charles and Jerry, i was able to solve the problem.

The case:

The Dell HBA330 has also feature, called EEDP.

If you want to know more, this website can explain it a little:
https://www.broadcom.com/support/knowledgebase/1211161502244/the-data-protection-feature---megaraid

In short:
End-to-end Data Protection (EEDP) is a feature in hard drives that
extends error detection to cover the entire path from the
computer system to the hard drive media and back.
Default=0 (EEDP support is enabled) (uint)

The problem here (also for ZFS-Setups) is that the mpt3sas is able to look behind the controller.
And sees actually the "entire path".

Major problem for me, i tried to disable it with mpt3sas.disable_eedp=1 which did not work.
Because there is a major lack of information on that feature.

With the help of Charles, pointing me in the right direction, the solution is this:
- mpt3sas.prot_mask=1  (https://lore.kernel.org/patchwork/patch/449635/)

I don't know why one is calling this eedp, the others prot_mask.
That was the most pain, to find the information on this.

On the other hand, i learned a lot about T10, harddrives and kernel-parameters. ;-)

Hopefully this explanation saves someone a lot of time in the future.

Best,

Timo


----- On 18. Mrz 2020, at 15:23, Timo Scheller t.scheller at its.uni-saarland.de wrote:

> [EXTERNAL EMAIL]
> 
> Dear Anthony,
> 
> thx for your quick response.
> 
> I can see all the disks in the idrac, yes.
> 
> Strange thing...
> 
> So i installed all of the systems with Ubuntu MAAS.
> Therefore, that it worked, i had to disable globally the mpt3sas as kernel
> parameter.
> 
> Then MAAS installed on Dell BOSS correctly.
> 
> After that i used ansible to remove the grub config.
> Made update-grub and rebootet the systems.
> 
> I now tried your suggestion. Slightly different.
> 
> Used one node and bootet with Ubuntu 18.04.4 server ISO.
> Installation went on smooth on the choosen BOSS.
> 
> After the installation, all came up as expected.
> No error messages or anything. I even can make a wipefs or
> mkfs without any trouble on this server.
> 
> Used also kernel-hwe (5.3.x)-
> 
> I already tried to figure out, what is different.
> Yet i can't put my finger on it.
> 
> Any ideas? Anything i missed? Any hint?
> 
> Would be really helpfull!
> 
> Thx a lot so far!
> 
> Best,
> 
> Timo
> 
> ----- On 18. Mrz 2020, at 8:13, Anthony Alba ascanio.alba7 at gmail.com wrote:
> 
>> On Tue, Mar 17, 2020 at 3:55 AM Timo Scheller
>> <t.scheller at its.uni-saarland.de> wrote:
>>>
>>>
>>> [EXTERNAL EMAIL]
>>>
>>> Dear all,
>>>
>>> we ordered a bunch of new Dell R740xd with the HBA330 Controller
>>> and 8TB Disks for Storage Services. They were delivered end of January.
>>>
>> Presumably you see all the pdisks correctly in iDRAC Web UI?
>> 
>> To confirm it is an 18.04 or Linux in general oddity,
>> can you see them correctly if you boot from a
>> 1. CentOS 7/Fedora 31 LiveCD or
>> 2. Ubuntu 20.04 (pre-release) LiveCD
>> 
>> 
>> Cheers
>> Anthony
> 
> _______________________________________________
> Linux-PowerEdge mailing list
> Linux-PowerEdge at dell.com
> https://lists.us.dell.com/mailman/listinfo/linux-poweredge
-------------- next part --------------
A non-text attachment was scrubbed...
Name: smime.p7s
Type: application/pkcs7-signature
Size: 2215 bytes
Desc: S/MIME Cryptographic Signature
URL: <http://lists.us.dell.com/pipermail/linux-poweredge/attachments/20200325/515080df/attachment.p7s>


More information about the Linux-PowerEdge mailing list