[Linux-PowerEdge] Idrac not accessible

Stefan M. Radman smr at kmi.com
Wed Dec 18 08:15:25 CST 2019


[EXTERNAL EMAIL] 


Is your iDRAC IP and your "public IP" on the same VLAN?

In the iDRAC Network Settings, what is your iDRAC NIC and Failover Network selection?

What NIC model do you operate on and what's the firmware version of the shared NIC?

I believe to remember reading about a similar scenario on this list in the past.
At that time I think the problem was the firmware of the shared NIC (not sure which vendor/make).
Check for a NIC firmware update.

Stefan

> On Dec 18, 2019, at 14:09, Werf, C.G. van der (Carel) <C.G.vanderWerf at uu.nl> wrote:
> 
> 
> [EXTERNAL EMAIL] 
> 
> Hi Patrice,
> 
> 1- Does local racadm work while IP not accessisble?  racadm getversion
> 
> Yes it does :
> racadm getversion
> Bios Version             = 3.4.1
> iDRAC Version            = 2.90
> USC Version              = 1.7.5.4
> These seem to be the latest versions.
> 
> 2- Do you have other similar servers that runs without problem?
> 
> As I stated:  I had been working fine with OMSA 9.0.1 And I have several other PE's (which I didn't update to OMSA 9.3.0) that do work ok.
> So they have a " shared " connection (idrac Express), though for each R815/R715/R730xd the "idrac-NIC" is not used inside the OS.
> Em1 : <not used> ; but connected for idrac-express.
> Em2 : public IP.
> Em3,Em4 :connected if necessary.
> 
> 3- And what if you stop OMSA daemons?  Does the iDRAC comes back?
> 
> Stopping the OMSA daemons or even disabling them and rebooting the server, did not solve the problem.
> With disabled OMSA, the kernel drivers are still loaded, I guess.
> 
> 4- On RH, can you see an IP address related to the idrac?  Does this address accessible?
> No as I mentioned ... No ping replies from idrac-IP (tested from outside this server offcourse)
> 
> 
> Carel
> 
> ________________________________________
> From: Linux-PowerEdge <linux-poweredge-bounces at dell.com> on behalf of Werf, C.G. van der (Carel) <C.G.vanderWerf at uu.nl>
> Sent: Wednesday, December 18, 2019 7:26 AM
> To: 'linux-poweredge at dell.com'
> Subject: [Linux-PowerEdge] Idrac not accessible
> 
> [EXTERNAL EMAIL]
> 
> Does anyone have experience with following scenario.
> 
> I have a DELL PE R815 with Idrac express.
> OS: Rhel 7.7 with OMSA 9.3.0
> 
> When system is powered off, idrac is fully accessible at it's configured IP-address. System can be powered on from idrac.
> 
> When system is running, incl the OMSA-daemons, the idrac IP-address is NOT accessible anymore (not even ping echoes).
> 
> When system is booted from external usb (for instance Ubuntu18), the idrac stays accessible.
> 
> So, my conclusion...there is something wrong with current OS,  presumably with OMSA 9.3.0 kernel-drivers, which reset the idrac interface.
> 
> This situation started when OMSA was upgraded from 9.0.1 (init.d-config) to 9.3.1 (systemd-config).
> 
> I have a Dell-support call running... but they don't seem to know.
> 
> With Regards,
> 
> | Carel van der Werf |
> | Developer/Administrator ICT-Bèta | Department of Science     | Utrecht University |
> 
> 
> _______________________________________________
> Linux-PowerEdge mailing list
> Linux-PowerEdge at dell.com
> https://nam04.safelinks.protection.outlook.com/?url=https%3A%2F%2Flists.us.dell.com%2Fmailman%2Flistinfo%2Flinux-poweredge&data=02%7C01%7Csmr%40kmi.com%7Cb140343d9dfe48e82e4a08d783bed25a%7Cc2283768b8d34e008f3d85b1b4f03b33%7C0%7C0%7C637122727930038766&sdata=3OieH5bqT9VUyw8BcaVYnZFA3hP2NaSICTy6VuNJupw%3D&reserved=0
> 
> _______________________________________________
> Linux-PowerEdge mailing list
> Linux-PowerEdge at dell.com
> https://nam04.safelinks.protection.outlook.com/?url=https%3A%2F%2Flists.us.dell.com%2Fmailman%2Flistinfo%2Flinux-poweredge&data=02%7C01%7Csmr%40kmi.com%7Cb140343d9dfe48e82e4a08d783bed25a%7Cc2283768b8d34e008f3d85b1b4f03b33%7C0%7C0%7C637122727930038766&sdata=3OieH5bqT9VUyw8BcaVYnZFA3hP2NaSICTy6VuNJupw%3D&reserved=0



More information about the Linux-PowerEdge mailing list