[Linux-PowerEdge] yum update fails on libsmbios.so.2 dependency error with srvadmin-storage-9.1.0-2757.12163.el7

francis picabia fpicabia at gmail.com
Fri Apr 20 07:25:04 CDT 2018


Running Redhat 7.4 and srvadmin packages of version 9.1.0-2757.12173

When updating the system I see a dependency error.

# cat /etc/yum.repos.d/dell-system-update.repo
[dell-system-update_independent]
name=dell-system-update_independent
baseurl=http://linux.dell.com/repo/hardware/dsu/os_independent/
gpgcheck=1
gpgkey=http://linux.dell.com/repo/hardware/dsu/public.key
enabled=1
exclude=dell-system-update*.i386

[dell-system-update_dependent]
name=dell-system-update_dependent
mirrorlist=
http://linux.dell.com/repo/hardware/dsu/mirrors.cgi?osname=el$releasever&basearch=$basearch&native=1
gpgcheck=1
gpgkey=http://linux.dell.com/repo/hardware/dsu/public.key
enabled=1


# yum update

{ ... }

--> Finished Dependency Resolution
Error: Package: srvadmin-storage-9.1.0-2757.12163.el7.x86_64
(@dell-system-update_dependent)
           Requires: libsmbios.so.2()(64bit)
           Removing: libsmbios-2.3.3-2.el7.x86_64 (@epel)
               libsmbios.so.2()(64bit)
           Updated By: libsmbios-2.3.3-6.el7.x86_64 (rhel-7-server-rpms)
               Not found
           Available: libsmbios-2.3.1-2757.12163.el7.x86_64
(dell-system-update_dependent)
               libsmbios.so.2()(64bit)
**********************************************************************
yum can be configured to try to resolve such errors by temporarily enabling
disabled repos and searching for missing dependencies.
To enable this functionality please set 'notify_only=0' in
/etc/yum/pluginconf.d/search-disabled-repos.conf
**********************************************************************

Error: Package: srvadmin-storage-9.1.0-2757.12163.el7.x86_64
(@dell-system-update_dependent)
           Requires: libsmbios.so.2()(64bit)
           Removing: libsmbios-2.3.3-2.el7.x86_64 (@epel)
               libsmbios.so.2()(64bit)
           Updated By: libsmbios-2.3.3-6.el7.x86_64 (rhel-7-server-rpms)
               Not found
           Available: libsmbios-2.3.1-2757.12163.el7.x86_64
(dell-system-update_dependent)
               libsmbios.so.2()(64bit)

===================================================================

Don't bother answering if you are going to suggest using --skip-broken
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.us.dell.com/pipermail/linux-poweredge/attachments/20180420/95c70f54/attachment.html>


More information about the Linux-PowerEdge mailing list