[Linux-PowerEdge] broken packaging

Marcus Elmäng marcus at netpanel.se
Wed Jun 29 08:45:12 CDT 2016


Hi.

Just want to confirm that there is problem with 8.3.

I was upgrading from OMSA 7.3 (or the last version on Wheezy) to Jessie
OMSA 8.3.
Dell R420 and R510.

Same problems as Elias.

I did purge and delete all files with great frustration and is now
waiting for a solution to be able to reinstall from scratch.

Best Regards
Marcus

Den 2016-06-29 kl. 14:47, skrev Elias Abacioglu:
> Hi
>
> The OMSA 8.3.0 packages are really packaged so bad that it doesn't
> even work on new installs.
> Upgrading fails, installing fails, uninstalling fails.
>
> The biggest problem is that files in /opt/dell/srvadmin/{bin,sbin}
> doesn't get correct modes.
> /opt/dell/srvadmin/sbin/CheckSystemType
> /opt/dell/srvadmin/sbin/dataeng.hotplug
> /opt/dell/srvadmin/sbin/srvadmin-services.sh
> /opt/dell/srvadmin/sbin/srvadmin-uninstall.sh
> /opt/dell/srvadmin/bin/omupdate
> /opt/dell/srvadmin/bin/stdcliproxy
>
> All of these files are missing execute bit.
>
> And I guess these files should also have excute bit.
> /opt/dell/srvadmin/lib64/srvadmin-omilcore/migrate-prior-om61.sh
> /opt/dell/srvadmin/lib64/srvadmin-omilcore/Funcs.sh
> /opt/dell/srvadmin/lib64/srvadmin-omilcore/migrate-legacy.sh
> /opt/dell/srvadmin/lib64/srvadmin-deng/register-deng.sh
> /opt/dell/srvadmin/lib64/srvadmin-deng/dcfwsnmp.sh
> /opt/dell/srvadmin/lib64/srvadmin-deng/unregister-deng.sh
> /opt/dell/srvadmin/lib64/srvadmin-omacore/unregister-omhip.sh
> /opt/dell/srvadmin/lib64/srvadmin-omacore/cli_ini_modifier.sh
> /opt/dell/srvadmin/lib64/srvadmin-omacore/unregister-omacore.sh
> /opt/dell/srvadmin/lib64/srvadmin-omacore/register-omacore.sh
> /opt/dell/srvadmin/lib64/srvadmin-omacore/register-omhip.sh
> /opt/dell/srvadmin/lib64/srvadmin-isvc/register-isvc.sh
> /opt/dell/srvadmin/lib64/srvadmin-isvc/unregister-isvc.sh
>
>  
> Another problem is that not all dependencies are installed. I here is
> a example
> # racadm jobqueue view
> /opt/dell/srvadmin/bin/idracadm7: error while loading shared
> libraries: libargtable2.so.0: cannot open shared object file: No such
> file or directory
>
> package libargtable2-0 must be depended so it would work.
>
> And there could be more problems, becuase I haven't installed all
> packages.
> I've installed following:
> srvadmin-base
> srvadmin-deng
> srvadmin-hapi
> srvadmin-idracadm7
> srvadmin-isvc
> srvadmin-omacore
> srvadmin-omacs
> srvadmin-omcommon
> srvadmin-omilcore
> srvadmin-ominst
> srvadmin-xmlsup
> syscfg
>
> Please shape up Dell, don't leave the non EL users in the dirt. I
> can't take to much of this shit.
>
>
>
>
> _______________________________________________
> Linux-PowerEdge mailing list
> Linux-PowerEdge at dell.com
> https://lists.us.dell.com/mailman/listinfo/linux-poweredge

-- 
Med vänlig hälsning / Best regards

Marcus Elmäng
WBS AB
Norra Ågatan 10
SE-41664 GÖTEBORG
+46 (0)31-209919 (tel kontor)
+46 (0)31-3390799 (fax)
Fillagring: https://wiki.inviso.se/index.php?title=Owncloud
Snabba och säkra servers i Sverige:  https://www.inviso.se
Domänregistrering: https://www.domanregister.se
Skicka SMS: https://www.SmartSMS.nu
PS Samla dina domäner och webbhotell hos oss.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.us.dell.com/pipermail/linux-poweredge/attachments/20160629/de36f76a/attachment-0001.html 


More information about the Linux-PowerEdge mailing list