[Linux-PowerEdge] broken packaging

Chandrasekhar_R at Dell.com Chandrasekhar_R at Dell.com
Wed Jun 29 08:39:15 CDT 2016


Dell - Internal Use - Confidential
Hello Mr Elias,

Thank you for sending this email. Can you please provide more details on this issue?

Which operating system you are using?
What are the steps you have followed to install the below mentioned packages?
Did you see any errors during installation?

Please provide us these details so that we will try to help you on this issue. Thanks once again.

Regards
Chandra


From: linux-poweredge-bounces-Lists On Behalf Of Elias Abacioglu
Sent: Wednesday, June 29, 2016 6:17 PM
To: linux-poweredge-Lists <linux-poweredge at lists.us.dell.com<mailto:linux-poweredge at lists.us.dell.com>>
Subject: [Linux-PowerEdge] broken packaging

Hi
The OMSA 8.3.0 packages are really packaged so bad that it doesn't even work on new installs.
Upgrading fails, installing fails, uninstalling fails.
The biggest problem is that files in /opt/dell/srvadmin/{bin,sbin} doesn't get correct modes.
/opt/dell/srvadmin/sbin/CheckSystemType
/opt/dell/srvadmin/sbin/dataeng.hotplug
/opt/dell/srvadmin/sbin/srvadmin-services.sh
/opt/dell/srvadmin/sbin/srvadmin-uninstall.sh
/opt/dell/srvadmin/bin/omupdate
/opt/dell/srvadmin/bin/stdcliproxy
All of these files are missing execute bit.
And I guess these files should also have excute bit.
/opt/dell/srvadmin/lib64/srvadmin-omilcore/migrate-prior-om61.sh
/opt/dell/srvadmin/lib64/srvadmin-omilcore/Funcs.sh
/opt/dell/srvadmin/lib64/srvadmin-omilcore/migrate-legacy.sh
/opt/dell/srvadmin/lib64/srvadmin-deng/register-deng.sh
/opt/dell/srvadmin/lib64/srvadmin-deng/dcfwsnmp.sh
/opt/dell/srvadmin/lib64/srvadmin-deng/unregister-deng.sh
/opt/dell/srvadmin/lib64/srvadmin-omacore/unregister-omhip.sh
/opt/dell/srvadmin/lib64/srvadmin-omacore/cli_ini_modifier.sh
/opt/dell/srvadmin/lib64/srvadmin-omacore/unregister-omacore.sh
/opt/dell/srvadmin/lib64/srvadmin-omacore/register-omacore.sh
/opt/dell/srvadmin/lib64/srvadmin-omacore/register-omhip.sh
/opt/dell/srvadmin/lib64/srvadmin-isvc/register-isvc.sh
/opt/dell/srvadmin/lib64/srvadmin-isvc/unregister-isvc.sh


Another problem is that not all dependencies are installed. I here is a example
# racadm jobqueue view
/opt/dell/srvadmin/bin/idracadm7: error while loading shared libraries: libargtable2.so.0: cannot open shared object file: No such file or directory
package libargtable2-0 must be depended so it would work.
And there could be more problems, becuase I haven't installed all packages.
I've installed following:
srvadmin-base
srvadmin-deng
srvadmin-hapi
srvadmin-idracadm7
srvadmin-isvc
srvadmin-omacore
srvadmin-omacs
srvadmin-omcommon
srvadmin-omilcore
srvadmin-ominst
srvadmin-xmlsup
syscfg
Please shape up Dell, don't leave the non EL users in the dirt. I can't take to much of this shit.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.us.dell.com/pipermail/linux-poweredge/attachments/20160629/b1d4194b/attachment.html 


More information about the Linux-PowerEdge mailing list