[Linux-PowerEdge] Need help with botched firmware update

Robert Jacobson teridon at gmail.com
Mon Aug 1 10:09:06 CDT 2016


FWIW, the problem I had was after using the DRM-created bootable ISO.  HOWEVER, I had installed an additional 4-port i350 card that was NOT provided by Dell.  So, it's probably not Dell's fault.  Lesson learned:  don't use third-party network add-on cards. :(

I stopped using the Linux ISOs mainly because they take too long.  The ISO will have maybe a hundred firmware packages on there; only a few are applicable to a particular server.  Then again, maybe I just haven't figured out the proper way to make sure that the ISO contains ONLY the firmware updates applicable to my hardware.  I would appreciate tips on this.

Anyway, my notes for using BootUtil are below.  Not sure OP has a similar problem, but I hope they help...


Fixed igb NVM checksum not valid error by booting from a DOS disk and running the intel "Bootutil.exe" program
make bootutil iso:
• make bootutil flash drive per 
	•  https://thesorcerer.wordpress.com/2011/07/01/guide-intel-82573l-gigabit-ethernet-with-ubuntu-11-04-and-fix-pxe-e05/ 
		○ download preboot.exe and extract it:  
https://downloadcenter.intel.com/Detail_Desc.aspx?agr=Y&DwnldID=19186&keyword=bootutil&DownloadType=Utilities,+Tools+and+Examples&OSFullname=OS+Independent&lang=eng 
	• now create bootable flash via:
			§ http://www.sevenforums.com/tutorials/46707-ms-dos-bootable-flash-drive-create.html 
		○ and copy the preboot folder to it
• make iso from the flash drive using imgburn
	• WARNING:  IMGBURN contains adware -- be careful when clicking through the installer
	•  http://superuser.com/questions/477569/how-can-i-create-a-bootable-dvd-iso-from-a-usb-drive 
		○ install/run ImgBurn
		○ Create bootable ISO per above web page, except see below
		○ on the bootable tab in imgburn, first extract the image from the flash drive, then it will prompt you to use the image in the current project -- select yes.
• now the ISO is bootable via DRAC
• boot it and run
	• bootutil -nic=5 -defcfg
		○ also played a bit but probably not neccesarry:
		○ bootutil -nic=5 -fe
		○ bootutil -nic=5 -fd
	• reboot machine
• booted Dell Firmware update ISO just to see if adapters were visible now -- they are!  
• booted ESX - adapters are visible again too!
• see also (maybe this will be easier next time):
	•  http://chtaube.eu/computers/freedos/bootable-usb/http://chtaube.eu/computers/freedos/bootable-usb/image-generation-howto/ 



> -----Original Message-----
> From: Rene Shuster [mailto:rene.shuster at bcsemail.org]
> Sent: Monday, August 01, 2016 10:34 AM
> To: Robert Jacobson <teridon at gmail.com>
> Cc: lhecking at users.sourceforge.net; linux-poweredge at dell.com
> Subject: Re: [Linux-PowerEdge] Need help with botched firmware update
> 
> LHecking,
> In the past half decade I ran into so many problems when updating NIC
> firmware through LC that I switched to a bootable Firmware Update ISO
> based on Linux. It never failed me in the last 2 years updating dozens of
> R720s, R710s, T710, R610 and T610s. Should be mount- and bootable through
> iDRAC although I never tried since I have physical access to them.
> 
> You can create it with the Dell Repository Manager or download a pre-
> authored one that includes every possible FW for a particular model. The
> pre-authored one you are looking for is located here:
> https://dell.app.box.com/v/bootabler720xd
> 
> Appropriately adjust the link for other models (e.g. the ISO for the R710
> is located @ https://dell.app.box.com/v/bootabler710).
> 
> 
> 
> 
> On Sun, Jul 31, 2016 at 1:42 PM, Robert Jacobson <teridon at gmail.com
> <mailto:teridon at gmail.com> > wrote:
> 
> 
> 	What model NIC?  I had a similar issue with some Intel I350 cards.
> 
> 	IIRC I had to put a DOS-mode Intel utility (BootUtil) onto a floppy
> image and boot from it via the DRAC.   I don't have access to my notes at
> the moment to give you exact details, but BootUtil fixed the cards'
> firmware.
> 
> 
> 	On Jul 30, 2016 7:30 PM, <lhecking at users.sourceforge.net
> <mailto:lhecking at users.sourceforge.net> > wrote:
> 
> 
> 
> 		 In brief: I ran dsu on an R720xd that had never seen a
> firmware update since
> 		 it was commissioned years ago. The NIC fw updates failed and
> seem to have
> 		 damaged the NICs or left them in an inconsistent state. It is
> no longer
> 		 possible to connect via network.
> 
> 		 The machine is in a remote location and I will advise local
> support to swap
> 		 in a new NIC card to bring it back online.
> 
> 		 As we still have iDRAC console access, is there anything to
> try and recover
> 		 this situation? Reboot does not help, or power cycling. What
> about power
> 		 cycling and unplugging power? An attempt to upgrade firmwares
> again via
> 		 Lifecycle controller will not work as there is no
> connectivity. Firmware
> 		 upgrade attempt via virtual media?
> 
> 		 I can't right now find out if it is still under support ...
> 
> 		_______________________________________________
> 		Linux-PowerEdge mailing list
> 		Linux-PowerEdge at dell.com <mailto:Linux-PowerEdge at dell.com>
> 		https://lists.us.dell.com/mailman/listinfo/linux-poweredge
> 
> 
> 
> 	_______________________________________________
> 	Linux-PowerEdge mailing list
> 	Linux-PowerEdge at dell.com <mailto:Linux-PowerEdge at dell.com>
> 	https://lists.us.dell.com/mailman/listinfo/linux-poweredge
> 
> 
> 
> 
> 
> 
> --
> 
> Tech III * AppControl * Endpoint Protection * Server Maintenance Buncombe
> County Schools Technology Department Network Group ComicSans Awareness
> Campaign <http://comicsanscriminal.com>



More information about the Linux-PowerEdge mailing list