[Linux-PowerEdge] Revisiting the LD Expansion story with a large boot disk (>2Tb)

vincent at cojot.name vincent at cojot.name
Tue Sep 22 13:22:04 CDT 2015


Hi everyone,

I have a T410 that used to have 2x2Tb as a LD boot drive (raid-1 config, 
MegaRAID SAS 9271-8i). I replaced the 2Tb drives with 4Tb drives one after 
the other. The Boot LD still shows up as 2Tb and I'd like to create 
another LD in the remaining space (so that the boot LD remains under 2Tb) 
but it seems MegaCli won't let me..

Here's the LD info:
 	# megaclisas-status
 	-- Controller information --
 	-- ID | H/W Model                  | RAM    | Temp | Firmware
 	c0    | LSI MegaRAID SAS 9271-8i   | 1024MB | 75C  | FW: 23.33.0-0023
 	[...]

 	-- Array information --
 	-- ID | Type   |    Size |  Strpsz |   Flags | DskCache |   Status |  OS Path | InProgress
 	c0u0  | RAID-1 |   1817G |  256 KB | ADRA,WT |  Enabled |  Optimal | /dev/sda | None
 	[...]

The drives are twice as big as the LD:
 	# megaclisas-status|grep c0u0
 	[...]
 	c0u0p0  | HDD  | WD-WCC4E0344739WDC WD40EFRX-68WT0N0 80.00A80 | 3.637 TB | Online, Spun Up | 6.0Gb/s  | 36C  | [252:4]  | 17
 	c0u0p1  | HDD  | WD-WCC4E0346931WDC WD40EFRX-68WT0N0 80.00A80 | 3.637 TB | Online, Spun Up | 6.0Gb/s  | 37C  | [252:5]  | 18

This LD is the boot LD:
 	# MegaCli -AdpBootDrive -get -a0

 	Adapter 0: Boot Virtual Drive - #0 (target id - 0).

 	# MegaCli -LDInfo -L0 -a0

 	Adapter 0 -- Virtual Drive Information:
 	Virtual Drive: 0 (Target Id: 0)
 	Name                :
 	RAID Level          : Primary-1, Secondary-0, RAID Level Qualifier-0
 	Size                : 1.817 TB
 	Sector Size         : 512
 	Is VD emulated      : Yes
 	Mirror Data         : 1.817 TB
 	State               : Optimal
 	Strip Size          : 256 KB
 	Number Of Drives    : 2
 	Span Depth          : 1

When I tried adding another LD to the boot drive group, I got this:

 	# MegaCli -CfgLdAdd -r1[252:4,252:5] -sz10GB -a0

 	Exit Code: 0x1a

( 0x1a means the maximum number of LD's has been reached.)

In a similar fashion, LD expansion shows up as impossible:

 	# MegaCli -getLdExpansionInfo -L0 -a0

 	Virtual Disk: 0 (Target Id: 0)
 	Expansion                                                : Not Possible

 	Exit Code: 0x00

 	# MegaCli -LdExpansion -p50 -dontExpandArray -L0 -a0

 	Expansion of Virtual Drive 0 on Adapter 0 is not possible due to space limitation.

 	Exit Code: 0x00

Is there a way to solve this in the current configuration or am I stuck 
with an LD/Drive Group I cannot expand?

My desired configuration would be to have two LD's on the two 4Tb drives 
in an RAID-1 so none of them would be above 2Tb..

Any ideas?

Thanks,

Vincent



More information about the Linux-PowerEdge mailing list