[Linux-PowerEdge] srvadmin-omcommon 7.2.0-4.459.1.el6 FAILS

Tony Molloy tony.molloy at ul.ie
Wed Jan 30 05:06:55 CST 2013


On Wednesday 30 January 2013 10:31:27 lejeczek wrote:
> #First:
> 
> Updated:
>    libvirt.x86_64 0:0.9.10-21.0.1.el6_3.8
> libvirt-client.x86_64 0:0.9.10-21.0.1.el6_3.8 nagios.x86_64
> 0:3.4.4-1.el6
>    nagios-common.x86_64 0:3.4.4-1.el6 srvadmin-deng.x86_64
> 0:7.2.0-4.183.1.el6 srvadmin-hapi.x86_64 0:7.2.0-4.237.1.el6
>    srvadmin-isvc.x86_64 0:7.2.0-4.325.1.el6
> srvadmin-omacore.x86_64 0:7.2.0-4.459.1.el6
> srvadmin-omilcore.x86_64 0:7.2.0-4.822.1.el6
>    srvadmin-realssd.x86_64 0:7.2.0-4.531.1.el6
> srvadmin-smcommon.x86_64 0:7.2.0-4.528.6.el6
> srvadmin-storage.x86_64 0:7.2.0-4.528.6.el6
>    srvadmin-storelib.x86_64 0:7.2.0-4.525.1.el6
> srvadmin-xmlsup.x86_64 0:7.2.0-4.458.1.el6 tzdata.noarch
> 0:2012j-1.el6
>    tzdata-java.noarch 0:2012j-1.el6
> 
> Failed:
>    srvadmin-omcommon.x86_64 0:7.2.0-4.450.1.el6
> srvadmin-omcommon.x86_64 0:7.2.0-4.459.1.el6
> 
> #Later
> 
> 
===================================================================
> 
===================================================================
> ========================= Package Arch Version
> Repository                              Size
> 
===================================================================
> 
===================================================================
> ========================= Updating:
>   srvadmin-omcommon x86_64 7.2.0-4.459.1.el6
> dell-omsa-indep                        1.8 M
> 
> Transaction Summary
> 
===================================================================
> 
===================================================================
> ========================= Upgrade       1 Package(s)
> 
> Total size: 1.8 M
> Is this ok [y/N]: y
> Downloading Packages:
> Running rpm_check_debug
> Running Transaction Test
> Transaction Test Succeeded
> Running Transaction
> Error in PREIN scriptlet in rpm package
> srvadmin-omcommon-7.2.0-4.459.1.el6.x86_64
> cp: cannot stat
> `/opt/dell/srvadmin/etc/openmanage/wwwroot/oem/data/ini/*ini':
> No such file or directory
> error: %pre(srvadmin-omcommon-7.2.0-4.459.1.el6.x86_64)
> scriptlet failed, exit status 1
> error:   install: %pre scriptlet failed (2), skipping
> srvadmin-omcommon-7.2.0-4.459.1.el6
> srvadmin-omcommon-7.2.0-4.450.1.el6.x86_64 was supposed to
> be removed but is not!
>    Verifying  : srvadmin-omcommon-7.2.0-4.450.1.el6.x86_64 1/2
>    Verifying  : srvadmin-omcommon-7.2.0-4.459.1.el6.x86_64 2/2
> 
> Failed:
>    srvadmin-
omcommon.x86_/opt/dell/srvadmin/etc/openmanage/wwwroot/oem/data/ini/64 
0:7.2.0-4.450.1.el6
> srvadmin-omcommon.x86_64 0:7.2.0-4.459.1.el6
> 
> 
> dell officials?
> 
> guys, do you even test it before releasing? no, seriously!
> this not the first time
> 
> regards
> 


What I did to workaround was :

  cd /opt/dell/srvadmin/etc/openmanage/wwwroot/oem/data/ini/

  touch x.ini
  
  yum update

Worked!!!

Funny I had this problem on two machines but not on a third which were 
configured exactly the same, go figure ;-)

Tony



More information about the Linux-PowerEdge mailing list