HOWTO Linux browser to iDRAC7 console

Dax Kelson dax at gurulabs.com
Wed Apr 25 12:31:36 CDT 2012


>From my Fedora 16 Linux workstation I could successfully connect to an
iDRAC6 console, but when I attempted to connect to an iDRAC7 console, I got
a popup with "Connection failed.".

In my ~/.xsession-errors file I had this:

Certificate host:foo-idrac
OS: Linux
OS Ver: 3.3.2-1.fc16.x86_64
m_ksFileName:/home/dkelson/.java/deployment/security/trusted.certs
04/24/2012 05:48:07:148:  Connection failed.

I didn't have a /home/dkelson/.java/deployment/ directory.

To fix this I I did the following.

Connect to iDRAC7 console from a freshly installed Windows box using java
(it worked). Search my Windows home directory for "trusted.certs", I found
it under the "AppData" directory tree. There were actually two files,
trusted.certs and trusted.jssecerts. FYI, the Windows box was using Java 7,
I don't know if that made a difference.

Back on my Linux box I ran:

mkdir -p /home/dkelson/.java/deployment/security/

I then copied the trusted.certs and trusted.jssecerts files from the
Windows box to that directory.

I was then able to successfully connect to the iDRAC7 console.

Hopefully this information will help someone else.

Dax Kelson
Guru Labs
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.us.dell.com/pipermail/linux-poweredge/attachments/20120425/6f64bc3f/attachment.html 


More information about the Linux-PowerEdge mailing list