Dell PE R515 Ethernet bonding in CentOS 6 problem

Howard Powell hbp4c at virginia.edu
Fri Jul 22 10:38:50 CDT 2011


Dimitri -

If you take a look at the RHEL6 guide, all options lines have been deprecated from the modprobe files to the ifcfg files instead. This is the reasoning for the BONDING_OPTS= line in my ifcfg-bond0 device. 

It looks like the old way may also work for now (putting an options line in modprobe.d/bonding.conf).

Adam's suggestion worked perfectly - removing the quotes from the MASTER=bond0 line in ifcfg-ethX convinces the network init script to load the slave devices.

Thanks for your ideas,
H

Howard Powell
hbp4c at virginia.edu




On Jul 21, 2011, at 8:47 AM, Dimitri Yioulos wrote:

> On Wednesday 20 July 2011 10:41:36 am Howard Powell wrote:
>> I have three Dell PowerEdge R515 systems which I have
>> configured alike with CentOS 6 x86_64.  Each system has the two
>> built-in Broadcom NetXtreme II adapter and an additional two
>> port Broadcom NetXtreme II network card, for a total of four
>> gigabit network ports per machine.  The NICs are up to date
>> with the latest firmware, and I've updated the OS to it's most
>> recent kernel.
>> 
>> I am unable to bond the network interfaces together in CentOS 6
>> like I was able to do in CentOS 5.
>> 
>> In C6, I have created a bonding.conf file in /etc/modprobe.d
>> and in it is the line: alias netdev-bond0 bonding
>> (note that the bond0 issues a depricated warning as of the
>> latest 2.6.32-71.29.1.el6.x86_64 kernel - so use the
>> recommended "netdev-bond0" instead).
>> 
>> I have created the file
>> /etc/sysconfig/network-scripts/ifcfg-bond0 with the following:
>> DEVICE="bond0"
>> BOOTPROTO="static"
>> DNS1="<my DNS>"
>> DNS2="<my DNS>"
>> DNS3="<my DNS>"
>> GATEWAY="<my gateway>"
>> IPADDR="<my aggregated IP address>"
>> NETMASK="255.255.0.0"
>> NM_CONTROLLED="yes"
>> ONBOOT="yes"
>> BONDING_OPTS="miimon=100 mode=6"
>> 
>> I have modified the /etc/sysconfig/network-script/ifcfg-eth?
>> files to each include the following: DEVICE="eth<the ethernet
>> interface>"
>> HWADDR="<the unique hardware address of each NIC>"
>> NM_CONTROLLED="yes"
>> ONBOOT="yes"
>> MASTER="bond0"
>> SLAVE="yes"
>> 
>> If I then issue a "service network restart" command, the bond0
>> interface will come up but no eth? interfaces will start.  I
>> have tested this on other systems (a Dell precision T3500) and
>> the eth? interfaces start correctly, as expected.  Bonding
>> these NICs worked in CentOS 5.6 with no problems.
>> 
>> I am able to "ifenslave bond0 eth?" each of the ethernet
>> interfaces, and the connection works.  However, upon reboot,
>> the system is does not start the slave interfaces and therefore
>> is not available on the network until someone manually enslaves
>> each interface.
>> 
>> It seems that the init scripts see the SLAVE="yes" comment of
>> the eth devices and ignores the interface.  As I noted though,
>> bonding works on other systems but the problem I have described
>> here is repeatable on each of my PE R515s.
>> 
>> I'm open to ideas.  Thanks!
>> Howard
>> 
>> 
>> 
>> Howard Powell
>> hbp4c at virginia.edu
> 
> 
> I think you need the following line in bonding.conf:
> 
> options bond0 miimon=100 mode=6
> 
> or, perhaps:
> 
> options netdev-bond0 miimon=100 mode=6
> 
> In my own set-up, anyway, I don't have the line in my ifcfg-bond0:
> 
> BONDING_OPTS=
> 
> but do have BOOTPROTO=none
> 
> HTH.
> 
> Dimitri
> 
> -- 
> This message has been scanned for viruses and
> dangerous content by MailScanner, and is
> believed to be clean.
> 
> _______________________________________________
> Linux-PowerEdge mailing list
> Linux-PowerEdge at dell.com
> https://lists.us.dell.com/mailman/listinfo/linux-poweredge

-------------- next part --------------
A non-text attachment was scrubbed...
Name: smime.p7s
Type: application/pkcs7-signature
Size: 4937 bytes
Desc: not available
Url : http://lists.us.dell.com/pipermail/linux-poweredge/attachments/20110722/0450f39d/attachment-0001.p7s 


More information about the Linux-PowerEdge mailing list