Updating firmware (dell_ft_install) --No such file or directory error

Mgia mgiashmera at lavabit.com
Thu Jul 14 09:19:21 CDT 2011


Hi Jeff,
> Could you post the output with the verbose(-v) option, also the log /var/log/firmware-updates.log ?

# update_firmware --yes -v
Checking Plugin (bootstrap_pci)
	Loaded bootstrap_pci plugin
Checking Plugin (bootstrap_cmd)
	Loaded bootstrap_cmd plugin
Checking Plugin (mock_inventory_bootstrap)
	Plugin mock_inventory_bootstrap not loaded: doesnt match load type
((4,))
Checking Plugin (dell_ft_ie_interface)
	Loaded dell_ft_ie_interface plugin
Checking Plugin (update_cmd)
	Loaded update_cmd plugin
Checking Plugin (listplugins_cmd)
	Loaded listplugins_cmd plugin
Checking Plugin (dellbios)
	Loaded dellbios plugin
Checking Plugin (mock_repository)
	Plugin mock_repository not loaded: doesnt match load type ((4,))
Checking Plugin (inventory_cmd)
	Loaded inventory_cmd plugin
Checking Plugin (dellbios_extract)
	Plugin raised DisablePlugin exception. skipping.

Running system inventory...
verobse INFO: hi there
Running IE Submodule
for /usr/libexec/dell_dup/dell_ie_tape_prostor-1.1.0
	Plugin command is DUPwrapper -s -i inv.xml
	Output file is inv.xml
	Plugin timeout is 300
output from the cmd was: 
<?xml version="1.0" encoding="UTF-8"?>
<SVMInventory lang="en">
</SVMInventory>

Running IE Submodule for /usr/libexec/dell_dup/dell_ie_bmc-1.1.0
	Module not for this system, disabling module.
Running IE Submodule for /usr/libexec/dell_dup/dell_ie_sas
	Plugin command is sasdupie -i -o inv.xml
	Output file is inv.xml
	Plugin timeout is 600
output from the cmd was: 
<?xml version="1.0" encoding="UTF-8"?><SVMInventory lang="en"><Device
vendorID="1000" deviceID="0058" subDeviceID="1f0e" subVendorID="1028"
bus="1" device="0" function="0" display="SAS6IR Controller 0"
impactsTPMmeasurements="TRUE"><Application componentType="FRMW"
version="00.25.47.00.06.22.03.00" display="SAS6IR Controller 0
Firmware"/></Device><Device componentID="00000" enum="CtrlId 1000000
DeviceId 0" display="WDC WD2502ABYS-1"><Application componentType="FRMW"
version="3B04" display="WDC WD2502ABYS-1 Firmware"/></Device><Device
componentID="00000" enum="CtrlId 1000000 DeviceId 1" display="WDC
WD2502ABYS-1"><Application componentType="FRMW" version="3B04"
display="WDC WD2502ABYS-1 Firmware"/></Device></SVMInventory>
Added DEVICE:
pci_firmware(ven_0x1000_dev_0x0058_subven_0x1028_subdev_0x1f0e)
Added DEVICE: dell_dup_componentid_00000
Added DEVICE: dell_dup_componentid_00000
Running IE Submodule for /usr/libexec/dell_dup/dell_ie_maser_ic
	Plugin command is MaserApp.sh -i -o=inv.xml
	Output file is inv.xml
	Plugin timeout is 1200
output from the cmd was: 
<?xml version="1.0" encoding="UTF-8" ?><SVMInventory lang="en"><SPStatus
result = "false"><Message id="1"> Inventory Failure: This Operating
System is not supported</Message></SPStatus></SVMInventory>

Running IE Submodule for /usr/libexec/dell_dup/dell_ie_rac_5
	Module not for this system, disabling module.
Running IE Submodule
for /usr/libexec/dell_dup/dell_ie_tape_quantum-1.1.0
	Plugin command is pvtapeupgwrapper -c
	Output file is scsiInv.txt
	Plugin timeout is 500
output from the cmd was: 
<?xml version="1.0" encoding="UTF-8"?>
<SVMInventory lang="en">
</SVMInventory>

Running IE Submodule
for /usr/libexec/dell_dup/dell_ie_tape_tandberg-1.1.0
	Plugin command is dupswrapper -c
	Output file is scsiInv.txt
	Plugin timeout is 400
output from the cmd was: 
<SVMInventory lang="en">
</SVMInventory>

Running IE Submodule for /usr/libexec/dell_dup/dell_ie_bp-1.1.0
	Module not for this system, disabling module.
Running IE Submodule for /usr/libexec/dell_dup/dell_ie_tape_ibm-1.1.0
	Plugin command is IbmDupwrapper -silent
	Output file is scsiInv.txt
	Plugin timeout is 500
output from the cmd was: 
<?xml version="1.0" encoding="UTF-8"?>
<SVMInventory lang="en">
</SVMInventory>

Running IE Submodule
for /usr/libexec/dell_dup/dell_ie_nic_broadcom-1.1.0
	Plugin command is dup_inv
	Output file is brcmfwinventory.xml
	Plugin timeout is 300
output from the cmd was: 

Invalid XML from module /usr/libexec/dell_dup/dell_ie_nic_broadcom-1.1.0
Running IE Submodule for /usr/libexec/dell_dup/dell_ie_bios
	Plugin command is biosie.bin -i inv.xml
	Output file is inv.xml
	Plugin timeout is 300
output from the cmd was: 
<?xml version="1.0" encoding="UTF-8" ?><SVMInventory lang="en"><Device
componentID= "159" display="BIOS"
impactsTPMmeasurements="TRUE"><Application componentType= "BIOS"
version="1.2.1" display = "BIOS" /></Device></SVMInventory>
Added DEVICE: dell_dup_componentid_00159
Running IE Submodule for /usr/libexec/dell_dup/dell_ie_nitrogen
	Plugin command is bmcie.sh -xml > inv.xml
	Output file is inv.xml
	Plugin timeout is 300
output from the cmd was: 
<?xml version="1.0" encoding="UTF-8" ?>
<SVMInventory lang="en">
   <Device componentID="20137" display="iDRAC6">
      <Application componentType="FRMW" version="1.30"
display="iDRAC6" />
   </Device>
</SVMInventory>

Added DEVICE: dell_dup_componentid_20137
Running IE Submodule for /usr/libexec/dell_dup/dell_ie_imc
	Module not for this system, disabling module.

Searching storage directory for available BIOS updates...
Checking BIOS - 1.2.1
	Available: dell_dup_componentid_00159 - 1.6.4
	Found Update: dell_dup_componentid_00159 - 1.6.4
Checking SAS6IR Controller 0 Firmware - 00.25.47.00.06.22.03.00
	Available:
pci_firmware(ven_0x1000_dev_0x0058_subven_0x1028_subdev_0x1f0e) -
00.25.47.00.06.22.03.00
	Did not find a newer package to install that meets all installation
checks.
Checking System BIOS for PowerEdge R210 - 1.2.1
	Did not find a newer package to install that meets all installation
checks.
Checking iDRAC6 - 1.30
	Available: dell_dup_componentid_20137 - 1.70
	Found Update: dell_dup_componentid_20137 - 1.70
Checking WDC WD2502ABYS-1 Firmware - 3b04
	Did not find a newer package to install that meets all installation
checks.

Found firmware which needs to be updated.

Running updates...
hey, we are supposed to be installing now... :)
/	Installing dell_dup_componentid_00159 - 1.6.4loading xml
from: /usr/libexec/dell_dup/BIOS_NONE/PIEConfig.xml
loaded.
	Plugin command is biosie.bin -u update.xml
	Output file is update.xml
	Plugin timeout is 600
-	Installing dell_dup_componentid_00159 - 1.6.4[Errno 2] Datei oder
Verzeichnis nicht gefunden: u'/tmp/firmware_installVbSuWM/ie/update.xml'
None
[Errno 2] Datei oder Verzeichnis nicht gefunden:
u'/tmp/firmware_installVbSuWM/ie/update.xml'

# cat /var/log/firmware-updates.log

2011-07-14 16:12:14,788: Attempting Firmware Update
2011-07-14 16:12:14,789: Attempted by user: *******************
2011-07-14 16:12:14,789: Package name: dell_dup_componentid_00159
2011-07-14 16:12:14,789: Package display name: Server BIOS 11G
2011-07-14 16:12:14,789: Package version: 1.6.4
2011-07-14 16:12:14,789: Devices:
2011-07-14 16:12:14,790: Device name: dell_dup_componentid_00159
2011-07-14 16:12:14,790: Device display name: BIOS
2011-07-14 16:12:14,790: Device version: 1.2.1
2011-07-14 16:12:14,855: Update result: The device is being updated now

Thanks for your reply.




More information about the Linux-PowerEdge mailing list