Firmware updates error on R410s

Robin Bowes robin-lists at robinbowes.com
Thu Mar 25 09:15:13 CDT 2010


On 25/03/10 13:54, Jeffrey_L_Mendoza at Dell.com wrote:
> 
> Do you have the firmware repo configured? It is obsoleted by the OM 
> 6.2 version of the hardware repo, this is where you are finding 
> 1.1.5. Go ahead and remove the firmware repo. To get all the
> updates, follow the instructions on the repo page: 
> http://linux.dell.com/repo/hardware/latest/ "yum install 
> dell_ft_install" instead of firmware-tools.

Ah, thanks - that was it.

I did the following:

yum remove firmware-tools
yum install dell_ft_install
yum -y install $(bootstrap_firmware)
update_firmware -y

I now get firmware 1.2.4 - still not 1.3.8.

> If you see that bios update issue, post the output with the verbose,
> -v, option.

I did. Here you go:

# update_firmware -y -v
Checking Plugin (bootstrap_pci)
	Loaded bootstrap_pci plugin
Checking Plugin (bootstrap_cmd)
	Loaded bootstrap_cmd plugin
Checking Plugin (mock_inventory_bootstrap)
	Plugin mock_inventory_bootstrap not loaded: doesnt match load type ((4,))
Checking Plugin (dell_ft_ie_interface)
	Loaded dell_ft_ie_interface plugin
Checking Plugin (update_cmd)
	Loaded update_cmd plugin
Checking Plugin (listplugins_cmd)
	Loaded listplugins_cmd plugin
Checking Plugin (dellbios)
	Loaded dellbios plugin
Checking Plugin (mock_repository)
	Plugin mock_repository not loaded: doesnt match load type ((4,))
Checking Plugin (inventory_cmd)
	Loaded inventory_cmd plugin
Checking Plugin (dellbios_extract)
	Plugin raised DisablePlugin exception. skipping.
hello world from update module doCheck()

Running system inventory...
loading xml from: /usr/libexec/dell_dup/PERC6_PERC/PIEConfig.xml
loaded.
not verbose --> INFO: hi there
verobse INFO: hi there
Running IE Submodule for /usr/libexec/dell_dup/dell_ie_tape_prostor-1.0.8
	Plugin command is DUPwrapper -s -i inv.xml
	Output file is inv.xml
	Plugin timeout is 300
output from the cmd was:
<?xml version="1.0" encoding="UTF-8"?>
<SVMInventory lang="en">
</SVMInventory>

Running IE Submodule for /usr/libexec/dell_dup/dell_ie_imc-1.0.8
	Module not for this system, disabling module.
Running IE Submodule for /usr/libexec/dell_dup/dell_ie_zappa-1.0.8
	Plugin command is PV2XX -i -x > inv.xml
	Output file is inv.xml
	Plugin timeout is 600
output from the cmd was:
<SVMInventory lang="en">
<SPStatus result="true"><Message id="1" >inventory
successful</Message></SPStatus >
</SVMInventory>

Running IE Submodule for /usr/libexec/dell_dup/dell_ie_nic_broadcom-1.0.8
	Plugin command is dup_inv
	Output file is brcmfwinventory.xml
	Plugin timeout is 300
output from the cmd was:
<?xml version="1.0" encoding="UTF-8"?>
<SVMInventory lang="en">
	<Device vendorID="14e4" deviceID="163b" subVendorID="1028"
subDeviceID="028c" bus="1" device="0" function="0" display="NetXtreme II
BCM5716 Gigabit Ethernet rev 20 (eth0)">
		<Application componentType="FRMW" version="5.0.9" display="NetXtreme
II BCM5716 Gigabit Ethernet rev 20 (eth0)" />
	</Device>
	<Device vendorID="14e4" deviceID="163b" subVendorID="1028"
subDeviceID="028c" bus="1" device="0" function="1" display="NetXtreme II
BCM5716 Gigabit Ethernet rev 20 (eth1)">
		<Application componentType="FRMW" version="5.0.9" display="NetXtreme
II BCM5716 Gigabit Ethernet rev 20 (eth1)" />
	</Device>
</SVMInventory>

Added DEVICE:
pci_firmware(ven_0x14e4_dev_0x163b_subven_0x1028_subdev_0x028c)
Added DEVICE:
pci_firmware(ven_0x14e4_dev_0x163b_subven_0x1028_subdev_0x028c)
Running IE Submodule for /usr/libexec/dell_dup/dell_ie_rac_4-1.0.8
	Module not for this system, disabling module.
Running IE Submodule for /usr/libexec/dell_dup/dell_ie_bmc-1.0.8
	Module not for this system, disabling module.
Running IE Submodule for /usr/libexec/dell_dup/dell_ie_tape_ibm-1.0.8
	Plugin command is IbmDupwrapper -silent
	Output file is scsiInv.txt
	Plugin timeout is 500
output from the cmd was:
<?xml version="1.0" encoding="UTF-8"?>
<SVMInventory lang="en">
</SVMInventory>

Running IE Submodule for /usr/libexec/dell_dup/dell_ie_sas-1.0.8
	Plugin command is sasdupie -i -o inv.xml
	Output file is inv.xml
	Plugin timeout is 600
output from the cmd was:
<?xml version="1.0" encoding="UTF-8"?><SVMInventory lang="en"><Device
vendorID="1000" deviceID="0060" subDeviceID="1f0b" subVendorID="1028"
bus="3" device="0" function="0" display="PERC 6/i Adapter Controller 0"
impactsTPMmeasurements="TRUE"><Application componentType="FRMW"
version="6.2.0-0013" display="PERC 6/i Adapter Controller 0
Firmware"/></Device><Device componentID="20513" enum="CtrlId 0 DeviceId
0" display="MBD2147RC"><Application componentType="FRMW" version="D606"
display="MBD2147RC Firmware"/></Device><Device componentID="20513"
enum="CtrlId 0 DeviceId 1" display="MBD2147RC"><Application
componentType="FRMW" version="D606" display="MBD2147RC
Firmware"/></Device><Device componentID="20513" enum="CtrlId 0 DeviceId
2" display="MBD2147RC"><Application componentType="FRMW" version="D606"
display="MBD2147RC Firmware"/></Device><Device componentID="20513"
enum="CtrlId 0 DeviceId 3" display="MBD2147RC"><Application
componentType="FRMW" version="D606" display="MBD2147RC
Firmware"/></Device><Device componentID="11204" enum="CtrlId 0 DeviceId
20 Backplane" display="SAS/SATA Backplane 0:0 Backplane"><Application
componentType="FRMW" version="1.07" display="SAS/SATA Backplane 0:0
Backplane Firmware"/></Device></SVMInventory>
Added DEVICE:
pci_firmware(ven_0x1000_dev_0x0060_subven_0x1028_subdev_0x1f0b)
Added DEVICE: dell_dup_componentid_20513
Added DEVICE: dell_dup_componentid_20513
Added DEVICE: dell_dup_componentid_20513
Added DEVICE: dell_dup_componentid_20513
Added DEVICE: dell_dup_componentid_11204
Running IE Submodule for /usr/libexec/dell_dup/dell_ie_maser_inv_lcl-1.0.8
	Plugin command is MaserIE -i -o=inv.xml
	Output file is inv.xml
	Plugin timeout is 1200
output from the cmd was:
<?xml version="1.0" encoding="UTF-8" ?><SVMInventory lang="en"><SPStatus
result = "false"><Message id="1"> Inventory Failure: This Operating
System is not supported</Message></SPStatus></SVMInventory>

Running IE Submodule for /usr/libexec/dell_dup/dell_ie_bios-1.0.8
	Plugin command is biosie.bin -i inv.xml
	Output file is inv.xml
	Plugin timeout is 300
output from the cmd was:
<?xml version="1.0" encoding="UTF-8" ?><SVMInventory lang="en"><Device
componentID= "159" display="BIOS"
impactsTPMmeasurements="TRUE"><Application componentType= "BIOS"
version="1.1.5" display = "BIOS" /></Device></SVMInventory>
Added DEVICE: dell_dup_componentid_00159
Running IE Submodule for /usr/libexec/dell_dup/dell_ie_bp-1.0.8
	Module not for this system, disabling module.
Running IE Submodule for /usr/libexec/dell_dup/dell_ie_rac_5-1.0.8
	Module not for this system, disabling module.
Running IE Submodule for /usr/libexec/dell_dup/dell_ie_tape_tandberg-1.0.8
	Plugin command is dupswrapper -c
	Output file is scsiInv.txt
	Plugin timeout is 400
output from the cmd was:
<SVMInventory lang="en">
</SVMInventory>

loading xml from: /usr/libexec/dell_dup/BROADCOM_FRMW/PIEConfig.xml
loaded.
loading xml from: /usr/libexec/dell_dup/BIOS_NONE/PIEConfig.xml
loaded.
loading xml from: /usr/libexec/dell_dup/SASHDD_SASHDD/PIEConfig.xml
loaded.
loading xml from: /usr/libexec/dell_dup/SASBP_SASBP/PIEConfig.xml
loaded.

Searching storage directory for available BIOS updates...
Checking BIOS - 1.1.5
	Available: dell_dup_componentid_00159 - 1.2.4
	Found Update: dell_dup_componentid_00159 - 1.2.4
Checking MBD2147RC Firmware - d606
	Available: dell_dup_componentid_20513 - d606
	Did not find a newer package to install that meets all installation checks.
Checking NetXtreme II BCM5716 Gigabit Ethernet rev 20 (eth1) - 5.0.9
	Did not find a newer package to install that meets all installation checks.
Checking NetXtreme II BCM5716 Gigabit Ethernet rev 20 (eth0) - 5.0.9
	Did not find a newer package to install that meets all installation checks.
Checking SAS/SATA Backplane 0:0 Backplane Firmware - 1.07
	Available: dell_dup_componentid_11204 - 1.05
	Did not find a newer package to install that meets all installation checks.
Checking PERC 6/i Adapter Controller 0 Firmware - 6.2.0-0013
	Available:
pci_firmware(ven_0x1000_dev_0x0060_subven_0x1028_subdev_0x1f0b) - 6.2.0-0013
	Did not find a newer package to install that meets all installation checks.
Checking System BIOS for PowerEdge R410 - 1.1.5
	Did not find a newer package to install that meets all installation checks.

Found firmware which needs to be updated.

Running updates...
hey, we are supposed to be installing now... :)
/	Installing dell_dup_componentid_00159 - 1.2.4	Plugin command is
biosie.bin -u update.xml
	Output file is update.xml
	Plugin timeout is 600
-	Installing dell_dup_componentid_00159 - 1.2.4output from the cmd was:

\	Installing dell_dup_componentid_00159 - 1.2.4no element found: line 1,
column 0
None
Traceback (most recent call last):
  File "/usr/sbin/update_firmware", line 23, in ?
    ftmain.main(sys.argv[1:])
  File "/usr/share/firmware-tools/ftmain.py", line 109, in main
    result, resultmsgs = base.doCommands()
  File "<firmwaretools.peak_util_decorators.rewrap wrapping
cli.doCommands at 0x2B8967ABC7D0>", line 3, in doCommands
  File
"/usr/lib/python2.4/site-packages/firmwaretools/trace_decorator.py",
line 81, in trace
    result = func(*args, **kw)
  File "/usr/share/firmware-tools/cli.py", line 134, in doCommands
    self.opts.mode, self.fullCmdLine, self.args)
  File "<firmwaretools.peak_util_decorators.rewrap wrapping
update_cmd.doCommand at 0x2B896866A410>", line 3, in doCommand
  File
"/usr/lib/python2.4/site-packages/firmwaretools/trace_decorator.py",
line 81, in trace
    result = func(*args, **kw)
  File "/usr/share/firmware-tools/plugins/update_cmd.py", line 69, in
doCommand
    base.updateFirmware(base.opts.show_unknown)
  File "<firmwaretools.peak_util_decorators.rewrap wrapping
cli.updateFirmware at 0x2B8967ABD0C8>", line 3, in updateFirmware
  File
"/usr/lib/python2.4/site-packages/firmwaretools/trace_decorator.py",
line 81, in trace
    result = func(*args, **kw)
  File "/usr/share/firmware-tools/cli.py", line 214, in updateFirmware
    ret = firmwaretools.pycompat.runLongProcess(pkg.install,
waitLoopFunction=statusFunc)
  File "<firmwaretools.peak_util_decorators.rewrap wrapping
firmwaretools.pycompat.runLongProcess at 0x2B89671975F0>", line 3, in
runLongProcess
  File
"/usr/lib/python2.4/site-packages/firmwaretools/trace_decorator.py",
line 81, in trace
    result = func(*args, **kw)
  File "/usr/lib/python2.4/site-packages/firmwaretools/pycompat.py",
line 177, in runLongProcess
    raise thread.exception
xml.parsers.expat.ExpatError: no element found: line 1, column 0


R.



More information about the Linux-PowerEdge mailing list