Firmware updates error on R410s

Robin Bowes robin-lists at robinbowes.com
Wed Mar 24 21:13:50 CDT 2010


On 25/03/10 01:30, Robin Bowes wrote:
> Hi,
> 
> I manage 34 R410s and 32 PE1950s. All run CentOS 5.4 and are deployed
> with cobbler and managed with puppet, ie. they're all configured
> identically.
> 
> I mirror the Dell repos with cobbler and deploy the appropriate yum repo
> config files with puppet.
> 
> On the PE1950s, update_firmware runs just fine. All my PE1950s are
> up-to-date.
> 
> However, on the R410s, I get the following error:
> 
> # update_firmware --yes
> hello world from update module doCheck()
> 
> Running system inventory...
> 
> Searching storage directory for available BIOS updates...
> Checking BIOS - 1.1.5
> 	Available: dell_dup_componentid_00159 - 1.2.4
> 	Found Update: dell_dup_componentid_00159 - 1.2.4

Hmmm, I've "fixed" things as follows:

yum remove firmware-tools
yum install firmware-tools
yum -y install $(bootstrap_firmware)
update_firmware -y

However, I no longer get BIOS version 1.2.4 installed - 1.1.5 seems to
be the latest.

Looking on the website, there seems to be a version 1.3.8 available for
the R410 [1].

It certainly seems that a couple of later firmware versions have been
released since 1.1.5 [2]

Is the yum firmware repository not kept up-to-date?

R.

[1]
http://support.dell.com/support/downloads/download.aspx?c=us&cs=555&l=en&s=biz&releaseid=R261066&SystemID=PWE_R410&servicetag=937C3L1&os=RH52&osl=en&deviceid=11809&devlib=0&typecnt=0&vercnt=4&catid=1&impid=-1&formatcnt=0&libid=1&typeid=-1&dateid=-1&formatid=-1&fileid=383136

[2]
http://support.dell.com/support/downloads/previousversions.aspx?c=us&cs=555&l=en&s=biz&SystemID=PWE_R410&releaseid=R261066&formatid=-1&deviceid=11809&formatcnt=5&dateid=-1&releasetype=BIOS&servicetag=&typeid=-1&catid=1&libid=1&impid=-1&osl=en&vercnt=4&os=RH52&checkFormat=false



More information about the Linux-PowerEdge mailing list