Dell R300 with Silicon Image 3132 PCIe SATA/eSATA card - doesn't work with BIOS v1.4.3

Tim Small tim at seoss.co.uk
Wed Mar 24 06:38:08 CDT 2010


Just a quick BIOS bug report -

I have this device working on a Dell R300 with BIOS version 1.2.0, but 
when I upgrade the R300 BIOS to 1.4.3, it doesn't show up in the PCI 
device listings.  I tried with Silicon Image BIOS versions 7.4.05 and 
7.7.02.

07:00.0 RAID bus controller: Silicon Image, Inc. SiI 3132 Serial ATA 
Raid II Controller (rev 01)
         Subsystem: Silicon Image, Inc. Device 7132
         Flags: bus master, fast devsel, latency 0, IRQ 16
         Memory at dfcfbf80 (64-bit, non-prefetchable) [size=128]
         Memory at dfcfc000 (64-bit, non-prefetchable) [size=16K]
         I/O ports at dc80 [size=128]
         Expansion ROM at dfc00000 [disabled] [size=512K]
         Capabilities: [54] Power Management version 2
         Capabilities: [5c] Message Signalled Interrupts: Mask- 64bit+ 
Queue=0/0 Enable-
         Capabilities: [70] Express Legacy Endpoint, MSI 00
         Capabilities: [100] Advanced Error Reporting <?>
         Kernel driver in use: sata_sil24
         Kernel modules: sata_sil24


I haven't tried the version of the same card which Dell sells -

http://search.dell.co.uk/1/2/13140-startech-com-2-port-pci-express-esata-controller-adapter-card-storage-controller-2-channel-esata-300-low-profile-pci-express-x1.html

but I'd expect the same results (both cards have just the sil3132 AKA 
sii3132 chip, and an EEPROM with the silicon image BIOS onboard).

Incidentally, you can program the EEPROM on this chip under Linux (I 
used Debian Squeeze) using the Silicon Image BIOS from 
http://www.siliconimage.com/docs/SiI3132_7702.zip along with "flashrom" 
from http://flashrom.org/

Cheers,

Tim.



More information about the Linux-PowerEdge mailing list