PERC6 and megacli (don't know where to ask)

Mikolaj Kucharski mikolaj at kucharski.name
Wed Jun 30 09:23:26 CDT 2010


Okay, resolved may problem. Decided to reboot and go to the PERC's BIOS,
and there wan't able to create logical drive a well, but got a hint from
POST screen errors message about preserved cache. Found an option in
PERC's BIOS to discard preserved cache.

Rebooted machine server back to get shell access and here what I can
see:



1. From my previous post:

$ wget -qO - \
	'http://marc.info/?l=linux-poweredge&m=127783081317102&q=raw' | \
	grep Preserved
Any Offline VD Cache Preserved   : Yes



2. After discarding cache from BIOS:

# megacli -AdpAllInfo -a0 -nolog | grep Preserved
Any Offline VD Cache Preserved   : No



3. I think here are relevant options which I should use:

# megacli -? -nolog | grep Preserved
MegaCli -GetPreservedCacheList -aN|-a0,1,2|-aALL
MegaCli -DiscardPreservedCache -Lx|-L0,1,2|-Lall -aN|-a0,1,2|-aALL



4. Now everything works as expected:

# megacli -cfgldadd -r0'[32:0]' WB NORA Direct -a0 -nolog

Adapter 0: Created VD 1

Adapter 0: Configured the Adapter!!

Exit Code: 0x00





On Tue, Jun 29, 2010 at 05:48:10PM +0100, Mikolaj Kucharski wrote:
> Hi,
> 
> Machine has two physical drives and each is configured as RAID0, so we
> have two logical drives.
> 
> One drive died, and I've replaced it with new one. Below are the
> commands which I ran, but I'm unable to re-create logical drive. I don't
> understand what it means "Refuse cfg add due to pinned cache" in the
> firmware log. I've tried various parameters to -CfgLdAdd but no luck so
> far.
> 
> # megacli -? -nolog | grep -A2 -i cfgldadd
> MegaCli -CfgLdAdd -rX[E0:S0,E1:S1,...] [WT|WB] [NORA|RA|ADRA] [Direct|Cached]
>         [CachedBadBBU|NoCachedBadBBU] [-szXXX [-szYYY ...]]
>         [-strpszM] [-Hsp[E0:S0,...]] [-AfterLdX] [-Force] -aN
> 
> 
> Do you guys know by any chance why firmware doesn't want to accept my
> request to create new logical drive? If you know any better place to
> ask, please let me know. Thanks.
> 
> BTW: I know I can reboot the server and try via PERC's BIOS, but wanted
> to understand why megacli is denying me creation of logical drive, as I
> did that in the past many times and megacli worked fine.
[...]

-- 
best regards
q#



More information about the Linux-PowerEdge mailing list