Error on OM firmware tools install: Centos 5.5

Shaun Qualheim shaun at qualheim.org
Fri Jun 25 09:17:31 CDT 2010


Hey all --

Getting an error on trying to install the firmware tools:

[*root at test log]# yum install dell_ft_install*
*Loaded plugins: fastestmirror*
*Loading mirror speeds from cached hostfile*
* * addons: centos.mbni.med.umich.edu*
* * base: ftp.ussg.iu.edu*
* * extras: centos.cs.wisc.edu*
* * updates: centos-distro.cavecreek.net*
*Setting up Install Process*
*Resolving Dependencies*
*--> Running transaction check*
*---> Package dell_ft_install.noarch 0:1.0-1 set to be updated*
*--> Processing Dependency: dell_ie_tape_ibm for package: dell_ft_install*
*--> Processing Dependency: dell_ie_rac_5 for package: dell_ft_install*
*--> Processing Dependency: dell_ie_maser_inv_lcl for package:
dell_ft_install*
*--> Processing Dependency: dell_ie_tape_prostor for package:
dell_ft_install*
*--> Processing Dependency: dell_ie_tape_tandberg for package:
dell_ft_install*
*--> Processing Dependency: dell_ie_imc for package: dell_ft_install*
*--> Processing Dependency: dell_ie_bios for package: dell_ft_install*
*--> Processing Dependency: dell_ie_bp for package: dell_ft_install*
*--> Processing Dependency: dell_ie_bmc for package: dell_ft_install*
*--> Processing Dependency: dell_ie_sas for package: dell_ft_install*
*--> Processing Dependency: dell_ie_zappa for package: dell_ft_install*
*--> Processing Dependency: dell_ie_rac_4 for package: dell_ft_install*
*--> Running transaction check*
*---> Package dell_ie_bios.noarch 0:1.0.8-1 set to be updated*
*--> Processing Dependency: dell_ft_ie_interface for package: dell_ie_bios*
*---> Package dell_ie_bmc.noarch 0:1.0.8-1 set to be updated*
*---> Package dell_ie_bp.noarch 0:1.0.8-1 set to be updated*
*---> Package dell_ie_imc.noarch 0:1.0.8-1 set to be updated*
*---> Package dell_ie_maser_inv_lcl.noarch 0:1.0.8-1 set to be updated*
*---> Package dell_ie_rac_4.noarch 0:1.0.8-1 set to be updated*
*---> Package dell_ie_rac_5.noarch 0:1.0.8-1 set to be updated*
*---> Package dell_ie_sas.noarch 0:1.0.8-1 set to be updated*
*---> Package dell_ie_tape_ibm.noarch 0:1.0.8-1 set to be updated*
*---> Package dell_ie_tape_prostor.noarch 0:1.0.8-1 set to be updated*
*---> Package dell_ie_tape_tandberg.noarch 0:1.0.8-1 set to be updated*
*---> Package dell_ie_zappa.noarch 0:1.0.8-1 set to be updated*
*--> Running transaction check*
*---> Package dell_ft_ie_interface.noarch 0:1.0.8-1.6.el5 set to be updated*
*--> Processing Dependency: firmware-tools >= 2.0.0 for package:
dell_ft_ie_interface*
*--> Processing Dependency: firmware-addon-dell >= 2.0 for package:
dell_ft_ie_interface*
*--> Running transaction check*
*---> Package firmware-addon-dell.x86_64 0:2.2.2-5.6.el5 set to be updated*
*--> Processing Dependency: python-smbios for package: firmware-addon-dell*
*--> Processing Dependency: smbios-utils for package: firmware-addon-dell*
*---> Package firmware-tools.noarch 0:2.1.9.d1-2.1.el5 set to be updated*
*--> Running transaction check*
*---> Package python-smbios.x86_64 0:2.2.19-10.1.el5 set to be updated*
*--> Processing Dependency: libsmbios = 2.2.19-10.1.el5 for package:
python-smbios*
*--> Processing Dependency: python-ctypes for package: python-smbios*
*---> Package smbios-utils.x86_64 0:2.2.19-10.1.el5 set to be updated*
*--> Processing Dependency: smbios-utils-python for package: smbios-utils*
*--> Running transaction check*
*--> Processing Dependency: libsmbios = 2.2.19-4.1.el5 for package:
smbios-utils-bin*
*---> Package libsmbios.i386 0:2.2.19-10.1.el5 set to be updated*
*---> Package libsmbios.x86_64 0:2.2.19-10.1.el5 set to be updated*
*---> Package python-ctypes.x86_64 0:1.0.2-1.1.el5 set to be updated*
*---> Package smbios-utils-python.x86_64 0:2.2.19-10.1.el5 set to be updated
*
*--> Finished Dependency Resolution*
*smbios-utils-bin-2.2.19-4.1.el5.i386 from installed has depsolving problems
*
*  --> Missing Dependency: libsmbios = 2.2.19-4.1.el5 is needed by package
smbios-utils-bin-2.2.19-4.1.el5.i386 (installed)*
*Error: Missing Dependency: libsmbios = 2.2.19-4.1.el5 is needed by package
smbios-utils-bin-2.2.19-4.1.el5.i386 (installed)*
* You could try using --skip-broken to work around the problem*
* You could try running: package-cleanup --problems*
*                        package-cleanup --dupes*
*                        rpm -Va --nofiles --nodigest*
*The program package-cleanup is found in the yum-utils package.*


It looks like it wants an update to the smbios-utils-bin.i386 package... but
unfortunately, no such update for the i386 package appears to be in
the repository.

I realize that there are sources I could build from... but is this a known
issue and will there be an update for the i386 package coming out soon?

OS: CentOS 5.5 x86-64

Thanks,
Shaun
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.us.dell.com/pipermail/linux-poweredge/attachments/20100625/e2eb4932/attachment.htm 


More information about the Linux-PowerEdge mailing list