Multipath install of RHEL/CentOS/fedora/OEL using kickstart

madunix madunix at gmail.com
Sat Jun 19 14:33:30 CDT 2010


look @
http://kbase.redhat.com/faq/docs/DOC-3691
http://kbase.redhat.com/faq/docs/DOC-17644
http://kbase.redhat.com/faq/docs/DOC-10146
http://kbase.redhat.com/faq/docs/DOC-17660
http://sources.redhat.com/lvm2/wiki/MultipathUsageGuide#Moving_root.2BAC8-swap_from_single_path_device_to_multipath_device


On Wed, Feb 4, 2009 at 1:05 PM, <christian.peper at kpn.com> wrote:

> No one responded to  my previous msg, so I'm simply asking again. :)
> http://lists.us.dell.com/pipermail/linux-poweredge/2009-January/038488.h
> tml<http://lists.us.dell.com/pipermail/linux-poweredge/2009-January/038488.h%0Atml>
>
> I hope other people have already tried to install RHEL/CentOS/Fedora/OEL
> on a PowerEdge with more than one HBA. I use kickstart to do this and we
> boot from SAN.
>
> Booting the installer with the 'linux mpath' enables anaconda to use
> multipath devices, i.e. /dev/mapper/* or /dev/mpath/*.
>
> The problem I run into is that I have 5 LUNs and the boot LUN's id is 0
> (zero), kickstart sees it as /dev/mapper/mpath4 as opposed to
> mapper/mpath0. I was hoping Linux would enumerate the devices in order
> of their LUN ids.
>
> I am wondering if therefore the boot device mapper/mpathX will vary as X
> will dependent on the number on LUNs the server sees at boot time. Has
> anyone tried this or ran into a similar issue? How did you resolve it,
> if you did?
>
> Cheers.
> ---
> Christian Peper
> Linux Engineer, KPN ITNL
>
> _______________________________________________
> Linux-PowerEdge mailing list
> Linux-PowerEdge at dell.com
> http://lists.us.dell.com/mailman/listinfo/linux-poweredge
> Please read the FAQ at http://lists.us.dell.com/faq
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.us.dell.com/pipermail/linux-poweredge/attachments/20100619/a84720ac/attachment.htm 


More information about the Linux-PowerEdge mailing list