dell 2850 initrd problem.

Tino Schwarze linux-poweredge.lists at tisc.de
Thu Jun 3 10:41:52 CDT 2010


Hi Ron,

the typical solution in such a case is: Restore from backup. :-|

On Thu, Jun 03, 2010 at 11:27:42AM -0400, Ron Croonenberg wrote:

> I found the FC3  rescuecd somewhere it is  2.6.12-1.667
> (that was what was initially installed.)
> 
> 
> btw:  I remember, before the reboot with the kernel panic, that  when I 
> booted the machine it said it booted from an unclean shutdown (or 
> something along that road).
> I thought a reboot would take care of that (but probably not with broken 
> raid memory)
> 
> I tried to boot with all 4 kernels (667,  1381 both  regular and smp)  
> and they all give me the same error.
> 
> I mounted the file system with the rescue cd and saw the following.
> 
> there is nothing in  /mnt/sysimage/initrd    (so if it tries to do 
> something with /initrd/dev I understand that can't work)
> 
> I also checked what is in  /etc (/mnt/sysimage/etc)   with:
> 
> ls /mnt/sysimage/etc/in*
> 
> I get:
> 
> /etc/init-d Input/Output error
> /etc/inittab Input/Output error
> /etc/initlog.conf Input/Output error
> 
> (btw, other places don't seem affected,  it looks like all the data etc 
> is there)

> Maybe I should run fsck on that drive (it is a raid) first, and than try 
> and see what happens?
> 
> Can I (I how do I) run fsck from the rescue cd?

I'd suggest running rpm --verify -a, then re-installing the affected 
packages. Of course, do 1) backup first, 2) run e2fsck on the partition.
Input/Output error is either a sign of severe filesystem corruption or a
sign of hardware failure - check your logs!

Recue CDs are design to allow fsck ;) - figure out the device, then use
it to run fsck. BE SURE TO HAVE BACKUPS! If the RAID had a problem, both
disks might be broken in different ways - I would not trust that data
without some serious integrity checks or similar.

HTH,

Tino.

-- 
"What we nourish flourishes." - "Was wir nähren erblüht."

www.lichtkreis-chemnitz.de
www.tisc.de



More information about the Linux-PowerEdge mailing list