SNMP on PowerEdge R710 with RHEL5

Dennis Ortsen dortsen at gmail.com
Wed Jul 21 04:49:30 CDT 2010


Hi everyone,

I've got a couple of PowerEdge R710 servers with RHEL5 (RHEL5.5 to be exact). I used to work with HP servers a lot (still have a few in production) and was hoping to achieve the same thing with the R710 servers, as with the DL380 servers:

I'd like to poll the R710's for the state of fans, power supply, System Event Log, RAID and temperature, using SNMP. For monitoring services and systems I use Xymon (formerly known as hobbit), together with Devmon (polls devices with SNMP).

For some reason, I can't get SNMP on the R710's to work completely. Net-SNMP itself works fine. I have tried installing the OMSA using the Dell yum repository (by installing the srvadmin-all package), but that doesn't seem to help much. After yum is finished, the following line is added in /etc/snmp/snmpd.conf:

# Allow Systems Management Data Engine SNMP to connect to snmpd using SMUX
smuxpeer .1.3.6.1.4.1.674.10892.1

With an snmpwalk I get some results from the Dell MIB back, but mostly OS related and partially about PCI slots, memory, USB information. But I don't need all that information. All I want is some information about the chassis itself, and the RAID status (PERC 6/i).

I have tried reinstalling, the srvadmin-all package, tried installing just the srvadmin-base and the srvadmin-deng packages, but to no avail. I don't get more information. When I login to the DRAC web interface, I can see the current state and values of the fans, temperature, power usage and so on. When I login to the OMSA webinterface (hostname:1311) as the root user, I can see the status of the PERC controller. Changing a value in the "Alert Management" tab however leads to an unresponsive OMSA webinterface. Restarting the OMSA services (srvadmin-services.sh restart) doesn't help to get the OMSA webinterface fully functional again.

Does anyone recognize this behaviour? I can see all the information I'd like to poll with SNMP in de DRAC and OMSA webinterface (which makes you believe all the components can be "read" by the higher software layer), but when doing an snmpwalk on the .1.3.6.1.4.1.674.10892.1 OID, I get a lot less results. Although according to the "Dell OpenManage Server Administrator Version 6.1 - SNMP Reference Guide" I should see a lot more Groups. I do see some, but not all. Here's a list with installed OMSA packages:

Jul 20 16:03:50 Installed: srvadmin-hapi-6.2.0-1.17.el5.i386
Jul 20 16:03:50 Installed: srvadmin-xmlsup-6.2.0-1.17.el5.i386
Jul 20 16:03:50 Installed: srvadmin-omilcore-6.2.0-1.9.el5.noarch
Jul 20 16:03:51 Installed: srvadmin-smcommon-6.2.0-1.29.el5.i386
Jul 20 16:03:51 Installed: srvadmin-deng-6.2.0-1.6.el5.i386
Jul 20 16:03:52 Installed: srvadmin-isvc-6.2.0-1.16.el5.i386
Jul 20 16:03:53 Installed: srvadmin-omcommon-6.2.0-1.19.el5.i386
Jul 20 16:03:55 Installed: srvadmin-omacore-6.2.0-1.18.el5.i386
Jul 20 16:03:55 Installed: srvadmin-cm-6.2.0-677.i386
Jul 20 16:03:55 Installed: srvadmin-base-6.2.0-1.5.el5.i386
Jul 20 16:03:55 Installed: srvadmin-omilcore-6.2.0-1.9.el5.noarch
Jul 20 16:03:55 Installed: srvadmin-deng-6.2.0-1.6.el5.i386
Jul 20 16:03:55 Installed: srvadmin-omacore-6.2.0-1.18.el5.i386
Jul 21 10:01:44 Installed: srvadmin-idrac-components-6.2.0-677.i386
Jul 21 10:01:44 Installed: srvadmin-racsvc-6.2.0-677.i386
Jul 21 10:01:44 Installed: srvadmin-racadm4-6.2.0-677.i386
Jul 21 10:01:45 Installed: srvadmin-rac4-components-6.2.0-677.i386
Jul 21 10:01:45 Installed: srvadmin-racdrsc4-6.2.0-677.i386
Jul 21 10:01:45 Installed: srvadmin-rac4-6.2.0-1.5.el5.i386
Jul 21 10:01:45 Installed: srvadmin-idracdrsc-6.2.0-677.i386
Jul 21 10:01:45 Installed: srvadmin-rac5-components-6.2.0-677.i386
Jul 21 10:01:45 Installed: srvadmin-racdrsc5-6.2.0-677.i386
Jul 21 10:01:45 Installed: srvadmin-fsa-6.2.0-1.6.el3.i386
Jul 21 10:01:46 Installed: srvadmin-idracadm-6.2.0-677.i386
Jul 21 10:01:46 Installed: srvadmin-idrac-6.2.0-1.5.el5.i386
Jul 21 10:01:50 Installed: srvadmin-jre-6.2.0-1.17.el5.i386
Jul 21 10:01:50 Installed: srvadmin-racadm5-6.2.0-677.i386
Jul 21 10:01:50 Installed: srvadmin-rac5-6.2.0-1.5.el5.i386
Jul 21 10:01:53 Installed: srvadmin-smweb-6.2.0-1.29.el5.i386
Jul 21 10:01:54 Installed: srvadmin-storage-6.2.0-1.29.el5.i386
Jul 21 10:01:54 Installed: srvadmin-sysfsutils-6.2.0-2.1.el5.i386
Jul 21 10:01:54 Installed: srvadmin-megalib-6.2.0-1.6.el3.i386
Jul 21 10:01:54 Installed: srvadmin-storelib-6.2.0-1.11.el3.i386
Jul 21 10:01:56 Installed: srvadmin-storage-populator-6.2.0-1.25.el3.i386
Jul 21 10:01:59 Installed: srvadmin-iws-6.2.0-1.18.el5.i386
Jul 21 10:01:59 Installed: srvadmin-storelib-libpci-6.2.0-1.1.el5.i386
Jul 21 10:01:59 Installed: srvadmin-storelib-sysfs-6.2.0-1.1.el5.i386
Jul 21 10:02:00 Installed: srvadmin-itunnelprovider-6.2.0-1.6.el5.i386
Jul 21 10:02:00 Installed: srvadmin-standardAgent-6.2.0-1.5.el5.i386
Jul 21 10:02:00 Installed: srvadmin-storageservices-6.2.0-10.1.2.el5.i386
Jul 21 10:02:00 Installed: srvadmin-webserver-6.2.0-1.5.el5.i386
Jul 21 10:02:00 Installed: srvadmin-all-6.2.0-1.5.el5.i386
Jul 21 10:02:00 Installed: srvadmin-iws-6.2.0-1.18.el5.i386

Thanks in advance,

Best regards,

Dennis






More information about the Linux-PowerEdge mailing list