OMSA 6.3 breaks yum (ESX 4)

Sean Dilda sean at duke.edu
Fri Jul 16 09:05:20 CDT 2010


Does anyone here have experience installed OMSA 6.3 with yum?   I'm 
attempting this on VMware ESX 4.0u2 which is based off RHEL5.   When I 
setup a yum repo and try to do the yum installs, I get this fun 
traceback from yum:


Traceback (most recent call last):
   File "/usr/lib/python2.4/site-packages/yum/rpmtrans.py", line 315, in 
callback
     self._instCloseFile(  bytes, total, h )
   File "/usr/lib/python2.4/site-packages/yum/rpmtrans.py", line 378, in 
_instCloseFile
     self.ts_done(txmbr.po, txmbr.output_state)
   File "/usr/lib/python2.4/site-packages/yum/rpmtrans.py", line 211, in 
ts_done
     te_fn = '%s/transaction-done.%s' % (self.base.conf.persistdir, 
self._ts_time)
AttributeError: RPMTransaction instance has no attribute '_ts_time'
error: python callback <bound method RPMTransaction.callback of 
<yum.rpmtrans.RPMTransaction instance at 0x1d6f9830>> failed, aborting!


When digging into it, it seems there's a known bug with yum in el5 where 
it breaks with %pretrans, and both the srvadmin-deng and 
srvadmin-omacore packages have a %pretrans script.


Has anyone else run into this?   Any suggestions on how to work around it?


Thanks,



Sean



More information about the Linux-PowerEdge mailing list