CentOS 5.2 and OMSA 6.2

Aaron Fraser aaronmfraser at gmail.com
Tue Jul 13 16:54:20 CDT 2010


I am attempting to install the latest version of OMSA onto a CentOS 5.2 Server in our STG environment. Ran into a small problem that is below. Seems to me that it was all working well and when it began installing the packages, something new was introduced that is different that 6.1 that is incompatible with my version of Yum or a yum/rpm dependency. this was run as root on this test server so there should be no permissions problems and I checked the dirs mentioned in the error, nothing weird going on. 

[root at sjcstgusr01 ~]# omreport about

Product name : Server Administrator
Version      : 6.1.0
Copyright    : Copyright (C) Dell Inc. 1995-2009. All rights reserved.
Company      : Dell Inc.

[root at sjcstgusr01 ~]# yum update srvadmin-all
Loading "dellsysid" plugin
Loading "fastestmirror" plugin
Loading mirror speeds from cached hostfile
 * yousendit: 172.17.6.10
 * dell-omsa-indep: 172.17.6.10
 * dell-omsa-specific: 172.17.6.10
 * base: 172.17.6.10
 * updates: 172.17.6.10
 * extras: 172.17.6.10
yousendit                 100% |=========================|  951 B    00:00     
dell-omsa-indep           100% |=========================| 1.9 kB    00:00     
dell-omsa-specific        100% |=========================| 1.9 kB    00:00     
base                      100% |=========================| 1.1 kB    00:00     
updates                   100% |=========================|  951 B    00:00     
extras                    100% |=========================|  951 B    00:00     
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package srvadmin-all.i386 0:6.2.0-1.5.el5 set to be updated
--> Processing Dependency: srvadmin-webserver = 6.2.0 for package: srvadmin-all
--> Processing Dependency: srvadmin-storageservices = 6.2.0 for package: srvadmin-all
--> Processing Dependency: srvadmin-base = 6.2.0 for package: srvadmin-all
--> Processing Dependency: srvadmin-idrac = 6.2.0 for package: srvadmin-all
--> Processing Dependency: srvadmin-rac4 = 6.2.0 for package: srvadmin-all
--> Processing Dependency: srvadmin-standardAgent = 6.2.0 for package: srvadmin-all
--> Processing Dependency: srvadmin-rac5 = 6.2.0 for package: srvadmin-all
--> Running transaction check
---> Package srvadmin-rac4.i386 0:6.2.0-1.5.el5 set to be updated
--> Processing Dependency: srvadmin-racdrsc4 = 6.2.0 for package: srvadmin-rac4
--> Processing Dependency: srvadmin-racadm4 = 6.2.0 for package: srvadmin-rac4
--> Processing Dependency: srvadmin-racsvc = 6.2.0 for package: srvadmin-rac4
---> Package srvadmin-storageservices.x86_64 0:6.2.0-10.1.2.el5 set to be updated
--> Processing Dependency: srvadmin-storelib-sysfs for package: srvadmin-storageservices
--> Processing Dependency: srvadmin-cm = 6.2.0 for package: srvadmin-storageservices
--> Processing Dependency: srvadmin-storelib = 6.2.0 for package: srvadmin-storageservices
--> Processing Dependency: srvadmin-storage-populator = 6.2.0 for package: srvadmin-storageservices
--> Processing Dependency: srvadmin-storage = 6.2.0 for package: srvadmin-storageservices
--> Processing Dependency: srvadmin-sysfsutils = 6.2.0 for package: srvadmin-storageservices
--> Processing Dependency: srvadmin-fsa = 6.2.0 for package: srvadmin-storageservices
--> Processing Dependency: srvadmin-megalib = 6.2.0 for package: srvadmin-storageservices
--> Processing Dependency: srvadmin-smcommon = 6.2.0 for package: srvadmin-storageservices
--> Processing Dependency: srvadmin-storelib-libpci for package: srvadmin-storageservices
---> Package srvadmin-standardAgent.i386 0:6.2.0-1.5.el5 set to be updated
--> Processing Dependency: srvadmin-itunnelprovider = 6.2.0 for package: srvadmin-standardAgent
---> Package srvadmin-idrac.i386 0:6.2.0-1.5.el5 set to be updated
--> Processing Dependency: srvadmin-idracdrsc = 6.2.0 for package: srvadmin-idrac
--> Processing Dependency: srvadmin-idracadm = 6.2.0 for package: srvadmin-idrac
---> Package srvadmin-rac5.i386 0:6.2.0-1.5.el5 set to be updated
--> Processing Dependency: srvadmin-racdrsc5 = 6.2.0 for package: srvadmin-rac5
--> Processing Dependency: srvadmin-racadm5 = 6.2.0 for package: srvadmin-rac5
---> Package srvadmin-base.i386 0:6.2.0-1.5.el5 set to be updated
--> Processing Dependency: srvadmin-omacore = 6.2.0 for package: srvadmin-base
---> Package srvadmin-webserver.i386 0:6.2.0-1.5.el5 set to be updated
--> Processing Dependency: srvadmin-iws = 6.2.0 for package: srvadmin-webserver
--> Processing Dependency: srvadmin-smweb = 6.2.0 for package: srvadmin-webserver
--> Running transaction check
---> Package srvadmin-idracdrsc.i386 0:6.2.0-677 set to be updated
--> Processing Dependency: srvadmin-idrac-components = 6.2.0 for package: srvadmin-idracdrsc
---> Package srvadmin-omacore.i386 0:6.2.0-1.18.el5 set to be updated
--> Processing Dependency: libomadb.so.4 for package: srvadmin-omacore
--> Processing Dependency: libomintf.so.3 for package: srvadmin-omacore
--> Processing Dependency: libomacs.so.1 for package: srvadmin-omacore
--> Processing Dependency: libdcsgen.so.5 for package: srvadmin-omacore
--> Processing Dependency: libdcsupt.so.5 for package: srvadmin-omacore
--> Processing Dependency: libdweb.so.1 for package: srvadmin-omacore
--> Processing Dependency: libxmlsup.so.2 for package: srvadmin-omacore
--> Processing Dependency: libdcecfl.so.5 for package: srvadmin-omacore
--> Processing Dependency: libdnet.so.1 for package: srvadmin-omacore
--> Processing Dependency: libdcship.so.5 for package: srvadmin-omacore
--> Processing Dependency: libdsupt.so.1 for package: srvadmin-omacore
---> Package srvadmin-storage-populator.i386 0:6.2.0-1.25.el3 set to be updated
--> Processing Dependency: libsmbios.so.2 for package: srvadmin-storage-populator
---> Package srvadmin-smweb.i386 0:6.2.0-1.29.el5 set to be updated
---> Package srvadmin-itunnelprovider.i386 0:6.2.0-1.6.el5 set to be updated
--> Processing Dependency: libcmpiCppImpl.so.0 for package: srvadmin-itunnelprovider
--> Processing Dependency: openwsman-client >= 2.1.5 for package: srvadmin-itunnelprovider
--> Processing Dependency: openwsman-server >= 2.1.5 for package: srvadmin-itunnelprovider
--> Processing Dependency: libwsman1 >= 2.1.5 for package: srvadmin-itunnelprovider
--> Processing Dependency: libcmpiCppImpl0 >= 2.0.0 for package: srvadmin-itunnelprovider
---> Package srvadmin-racadm4.i386 0:6.2.0-677 set to be updated
--> Processing Dependency: srvadmin-omilcore = 6.2.0 for package: srvadmin-racadm4
---> Package srvadmin-iws.i386 0:6.2.0-1.18.el5 set to be updated
---> Package srvadmin-cm.i386 0:6.2.0-677 set to be updated
---> Package srvadmin-storelib.i386 0:6.2.0-1.11.el3 set to be updated
---> Package srvadmin-racdrsc4.i386 0:6.2.0-677 set to be updated
--> Processing Dependency: srvadmin-rac4-components = 6.2.0 for package: srvadmin-racdrsc4
---> Package srvadmin-racadm5.i386 0:6.2.0-677 set to be updated
--> Processing Dependency: srvadmin-hapi = 6.2.0 for package: srvadmin-racadm5
---> Package srvadmin-megalib.i386 0:6.2.0-1.6.el3 set to be updated
---> Package srvadmin-storelib-sysfs.i386 0:6.2.0-1.1.el5 set to be updated
---> Package srvadmin-racdrsc5.i386 0:6.2.0-677 set to be updated
--> Processing Dependency: srvadmin-rac5-components = 6.2.0 for package: srvadmin-racdrsc5
---> Package srvadmin-idracadm.i386 0:6.2.0-677 set to be updated
---> Package srvadmin-racsvc.i386 0:6.2.0-677 set to be updated
---> Package srvadmin-sysfsutils.i386 0:6.2.0-2.1.el5 set to be updated
---> Package srvadmin-smcommon.i386 0:6.2.0-1.29.el5 set to be updated
---> Package srvadmin-storage.i386 0:6.2.0-1.29.el5 set to be updated
---> Package srvadmin-storelib-libpci.i386 0:6.2.0-1.1.el5 set to be updated
---> Package srvadmin-fsa.i386 0:6.2.0-1.6.el3 set to be updated
--> Running transaction check
---> Package srvadmin-xmlsup.i386 0:6.2.0-1.17.el5 set to be updated
--> Processing Dependency: libxslt.so.1 for package: srvadmin-xmlsup
---> Package srvadmin-omcommon.i386 0:6.2.0-1.19.el5 set to be updated
--> Processing Dependency: srvadmin-omilcore = 6.1.0 for package: srvadmin-jre
--> Processing Dependency: libsmbios = 2.2.17-3.1.el5 for package: python-smbios
---> Package srvadmin-rac4-components.i386 0:6.2.0-677 set to be updated
---> Package srvadmin-rac5-components.i386 0:6.2.0-677 set to be updated
---> Package srvadmin-isvc.i386 0:6.2.0-1.16.el5 set to be updated
---> Package srvadmin-hapi.i386 0:6.2.0-1.17.el5 set to be updated
---> Package libwsman1.i386 0:2.1.5Dell-2.1.el5 set to be updated
---> Package srvadmin-deng.i386 0:6.2.0-1.6.el5 set to be updated
---> Package libcmpiCppImpl0.i386 0:2.0.0Dell-1.1.el5 set to be updated
---> Package srvadmin-omilcore.noarch 0:6.2.0-1.9.el5 set to be updated
--> Processing Dependency: smbios-utils-bin for package: srvadmin-omilcore
---> Package openwsman-client.i386 0:2.1.5Dell-2.1.el5 set to be updated
---> Package srvadmin-idrac-components.i386 0:6.2.0-677 set to be updated
---> Package libsmbios.x86_64 0:2.2.19-10.1.el5 set to be updated
---> Package libsmbios.i386 0:2.2.19-10.1.el5 set to be updated
---> Package openwsman-server.i386 0:2.1.5Dell-2.1.el5 set to be updated
--> Running transaction check
---> Package python-smbios.x86_64 0:2.2.19-10.1.el5 set to be updated
--> Processing Dependency: python-smbios = 2.2.17-3.1.el5 for package: smbios-utils-python
---> Package srvadmin-jre.i386 0:6.2.0-1.17.el5 set to be updated
---> Package smbios-utils-bin.x86_64 0:2.2.19-10.1.el5 set to be updated
---> Package libxslt.i386 0:1.1.17-2.el5_2.2 set to be updated
--> Running transaction check
---> Package smbios-utils-python.x86_64 0:2.2.19-10.1.el5 set to be updated
--> Processing Dependency: smbios-utils-python = 2.2.17-3.1.el5 for package: yum-dellsysid
--> Running transaction check
---> Package yum-dellsysid.x86_64 0:2.2.19-10.1.el5 set to be updated
--> Finished Dependency Resolution

Dependencies Resolved

=============================================================================
 Package                 Arch       Version          Repository        Size 
=============================================================================
Installing:
 srvadmin-itunnelprovider  i386       6.2.0-1.6.el5    dell-omsa-indep   2.0 M
     replacing  srvadmin-ssa.i386 6.1.0-648.rhel5

 srvadmin-omacore        i386       6.2.0-1.18.el5   dell-omsa-indep   1.7 M
     replacing  srvadmin-omhip.i386 6.1.0-648

 srvadmin-omcommon       i386       6.2.0-1.19.el5   dell-omsa-indep   4.1 M
     replacing  srvadmin-wsmanclient.i386 6.1.0-648.rhel5

 srvadmin-omilcore       noarch     6.2.0-1.9.el5    dell-omsa-indep    28 k
     replacing  srvadmin-syscheck.i386 6.1.0-648

Updating:
 libsmbios               x86_64     2.2.19-10.1.el5  dell-omsa-indep   1.5 M
 libwsman1               i386       2.1.5Dell-2.1.el5  dell-omsa-indep   211 k
 openwsman-client        i386       2.1.5Dell-2.1.el5  dell-omsa-indep   115 k
 openwsman-server        i386       2.1.5Dell-2.1.el5  dell-omsa-indep   146 k
 srvadmin-all            i386       6.2.0-1.5.el5    dell-omsa-indep   2.5 k
 srvadmin-base           i386       6.2.0-1.5.el5    dell-omsa-indep   2.4 k
 srvadmin-cm             i386       6.2.0-677        dell-omsa-indep    17 M
 srvadmin-deng           i386       6.2.0-1.6.el5    dell-omsa-indep   714 k
 srvadmin-hapi           i386       6.2.0-1.17.el5   dell-omsa-indep   817 k
 srvadmin-idrac          i386       6.2.0-1.5.el5    dell-omsa-indep   2.4 k
 srvadmin-idrac-components  i386       6.2.0-677        dell-omsa-indep    62 k
 srvadmin-idracadm       i386       6.2.0-677        dell-omsa-indep   2.6 M
 srvadmin-idracdrsc      i386       6.2.0-677        dell-omsa-indep    17 k
 srvadmin-isvc           i386       6.2.0-1.16.el5   dell-omsa-indep   6.2 M
 srvadmin-iws            i386       6.2.0-1.18.el5   dell-omsa-indep   4.9 M
 srvadmin-rac4           i386       6.2.0-1.5.el5    dell-omsa-indep   2.4 k
 srvadmin-rac4-components  i386       6.2.0-677        dell-omsa-indep    52 k
 srvadmin-rac5           i386       6.2.0-1.5.el5    dell-omsa-indep   2.4 k
 srvadmin-rac5-components  i386       6.2.0-677        dell-omsa-indep    61 k
 srvadmin-racadm4        i386       6.2.0-677        dell-omsa-indep   190 k
 srvadmin-racadm5        i386       6.2.0-677        dell-omsa-indep   1.3 M
 srvadmin-racdrsc4       i386       6.2.0-677        dell-omsa-indep    16 k
 srvadmin-racdrsc5       i386       6.2.0-677        dell-omsa-indep    17 k
 srvadmin-racsvc         i386       6.2.0-677        dell-omsa-indep    66 k
 srvadmin-standardAgent  i386       6.2.0-1.5.el5    dell-omsa-indep   2.4 k
 srvadmin-storage        i386       6.2.0-1.29.el5   dell-omsa-indep   778 k
 srvadmin-storageservices  x86_64     6.2.0-10.1.2.el5  dell-omsa-indep   2.6 k
 srvadmin-webserver      i386       6.2.0-1.5.el5    dell-omsa-indep   2.4 k
Installing for dependencies:
 libcmpiCppImpl0         i386       2.0.0Dell-1.1.el5  dell-omsa-indep    93 k
 libsmbios               i386       2.2.19-10.1.el5  dell-omsa-indep   1.5 M
 libxslt                 i386       1.1.17-2.el5_2.2  updates           485 k
 smbios-utils-bin        x86_64     2.2.19-10.1.el5  dell-omsa-indep   117 k
 srvadmin-fsa            i386       6.2.0-1.6.el3    dell-omsa-indep   2.6 k
 srvadmin-megalib        i386       6.2.0-1.6.el3    dell-omsa-indep   528 k
 srvadmin-smcommon       i386       6.2.0-1.29.el5   dell-omsa-indep   592 k
 srvadmin-smweb          i386       6.2.0-1.29.el5   dell-omsa-indep    12 M
 srvadmin-storage-populator  i386       6.2.0-1.25.el3   dell-omsa-indep   1.2 M
 srvadmin-storelib       i386       6.2.0-1.11.el3   dell-omsa-indep   277 k
 srvadmin-storelib-libpci  i386       6.2.0-1.1.el5    dell-omsa-indep    41 k
 srvadmin-storelib-sysfs  i386       6.2.0-1.1.el5    dell-omsa-indep    41 k
 srvadmin-sysfsutils     i386       6.2.0-2.1.el5    dell-omsa-indep    47 k
 srvadmin-xmlsup         i386       6.2.0-1.17.el5   dell-omsa-indep    49 k
Updating for dependencies:
 python-smbios           x86_64     2.2.19-10.1.el5  dell-omsa-indep    69 k
 smbios-utils-python     x86_64     2.2.19-10.1.el5  dell-omsa-indep    56 k
 srvadmin-jre            i386       6.2.0-1.17.el5   dell-omsa-indep    40 M
 yum-dellsysid           x86_64     2.2.19-10.1.el5  dell-omsa-indep    15 k

Transaction Summary
=============================================================================
Install     18 Package(s)         
Update      32 Package(s)         
Remove       0 Package(s)         

Total download size: 102 M
Is this ok [y/N]: y
Downloading Packages:
(1/50): srvadmin-storelib 100% |=========================|  41 kB    00:00     
(2/50): srvadmin-standard 100% |=========================| 2.4 kB    00:00     
(3/50): libxslt-1.1.17-2. 100% |=========================| 485 kB    00:00     
(4/50): srvadmin-base-6.2 100% |=========================| 2.4 kB    00:00     
(5/50): srvadmin-idracadm 100% |=========================| 2.6 MB    00:01     
(6/50): libcmpiCppImpl0-2 100% |=========================|  93 kB    00:00     
(7/50): srvadmin-rac4-6.2 100% |=========================| 2.4 kB    00:00     
(8/50): srvadmin-racdrsc5 100% |=========================|  17 kB    00:00     
(9/50): srvadmin-racadm5- 100% |=========================| 1.3 MB    00:00     
(10/50): srvadmin-rac4-co 100% |=========================|  52 kB    00:00     
(11/50): srvadmin-all-6.2 100% |=========================| 2.5 kB    00:00     
(12/50): smbios-utils-bin 100% |=========================| 117 kB    00:00     
(13/50): srvadmin-idrac-6 100% |=========================| 2.4 kB    00:00     
(14/50): srvadmin-omacore 100% |=========================| 1.7 MB    00:00     
(15/50): srvadmin-idracdr 100% |=========================|  17 kB    00:00     
(16/50): libsmbios-2.2.19 100% |=========================| 1.5 MB    00:00     
(17/50): srvadmin-omcommo 100% |=========================| 4.1 MB    00:01     
(18/50): srvadmin-smcommo 100% |=========================| 592 kB    00:00     
(19/50): openwsman-server 100% |=========================| 146 kB    00:00     
(20/50): libwsman1-2.1.5D 100% |=========================| 211 kB    00:00     
(21/50): srvadmin-jre-6.2 100% |=========================|  40 MB    00:32     
(22/50): srvadmin-webserv 100% |=========================| 2.4 kB    00:00     
(23/50): srvadmin-megalib 100% |=========================| 528 kB    00:00     
(24/50): srvadmin-hapi-6. 100% |=========================| 817 kB    00:00     
(25/50): srvadmin-cm-6.2. 100% |=========================|  17 MB    00:06     
(26/50): srvadmin-itunnel 100% |=========================| 2.0 MB    00:01     
(27/50): srvadmin-storage 100% |=========================| 778 kB    00:00     
(28/50): srvadmin-idrac-c 100% |=========================|  62 kB    00:00     
(29/50): openwsman-client 100% |=========================| 115 kB    00:00     
(30/50): srvadmin-sysfsut 100% |=========================|  47 kB    00:00     
(31/50): srvadmin-omilcor 100% |=========================|  28 kB    00:00     
(32/50): srvadmin-isvc-6. 100% |=========================| 6.2 MB    00:02     
(33/50): srvadmin-racdrsc 100% |=========================|  16 kB    00:00     
(34/50): smbios-utils-pyt 100% |=========================|  56 kB    00:00     
(35/50): srvadmin-racadm4 100% |=========================| 190 kB    00:00     
(36/50): srvadmin-storage 100% |=========================| 2.6 kB    00:00     
(37/50): srvadmin-xmlsup- 100% |=========================|  49 kB    00:00     
(38/50): srvadmin-iws-6.2 100% |=========================| 4.9 MB    00:02     
(39/50): srvadmin-fsa-6.2 100% |=========================| 2.6 kB    00:00     
(40/50): srvadmin-racsvc- 100% |=========================|  66 kB    00:00     
(41/50): srvadmin-rac5-6. 100% |=========================| 2.4 kB    00:00     
(42/50): srvadmin-storeli 100% |=========================|  41 kB    00:00     
(43/50): srvadmin-deng-6. 100% |=========================| 714 kB    00:00     
(44/50): srvadmin-storeli 100% |=========================| 277 kB    00:00     
(45/50): srvadmin-rac5-co 100% |=========================|  61 kB    00:00     
(46/50): libsmbios-2.2.19 100% |=========================| 1.5 MB    00:00     
(47/50): srvadmin-smweb-6 100% |=========================|  12 MB    00:09     
(48/50): srvadmin-storage 100% |=========================| 1.2 MB    00:00     
(49/50): python-smbios-2. 100% |=========================|  69 kB    00:00     
(50/50): yum-dellsysid-2. 100% |=========================|  15 kB    00:00     
Running rpm_check_debug
Running Transaction Test
/var/tmp/rpm-tmp.56447: line 1: /opt/dell/srvadmin/var/log/openmanage/install.log: No such file or directory
/var/tmp/rpm-tmp.56447: line 1: /opt/dell/srvadmin/var/log/openmanage/install.log: No such file or directory
/var/tmp/rpm-tmp.56447: line 2: /opt/dell/srvadmin/lib/srvadmin-omilcore/migrate-legacy.sh: No such file or directory
/var/tmp/rpm-tmp.56447: line 1: /opt/dell/srvadmin/var/log/openmanage/install.log: No such file or directory
Finished Transaction Test
Transaction Test Succeeded
Running Transaction
WARNING: srvadmin-storage configuration not performed;
         '/etc/omreg.cfg' is missing or damaged.
srvadmin-omacore: required file entry, openmanage.syslistfile, does not exist in /etc/omreg.cfg
srvadmin-omacore: required file entry, openmanage.syslistfile, does not exist in /etc/omreg.cfg
srvadmin-omacore: required file entry, openmanage.syslistfile, does not exist in /etc/omreg.cfg
/opt/dell/srvadmin/funcs/srvadmin-rac4-components.sh: line 1410: [: !=: unary operator expected
Traceback (most recent call last):
  File "/usr/bin/yum", line 29, in ?
    yummain.main(sys.argv[1:])
  File "/usr/share/yum-cli/yummain.py", line 183, in main
    base.doTransaction()
  File "/usr/share/yum-cli/cli.py", line 408, in doTransaction
    self.runTransaction(cb=cb)
  File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 599, in runTransaction
    errors = self.ts.run(cb.callback, '')
  File "/usr/lib/python2.4/site-packages/yum/rpmtrans.py", line 315, in callback
    self._instCloseFile(  bytes, total, h )
  File "/usr/lib/python2.4/site-packages/yum/rpmtrans.py", line 378, in _instCloseFile
    self.ts_done(txmbr.po, txmbr.output_state)
  File "/usr/lib/python2.4/site-packages/yum/rpmtrans.py", line 211, in ts_done
    te_fn = '%s/transaction-done.%s' % (self.base.conf.persistdir, self._ts_time)
AttributeError: RPMTransaction instance has no attribute '_ts_time'



On Jul 13, 2010, at 2:37 PM, tom wrote:

> Please detail the problems.
> 
> Aaron Fraser wrote:
>> Having issues installing OMSA 6.2 onto CentOS 5.2. Is there any hack or am i stuck with having to update to CentOS 5.4+?
>> 
>> - Aaron Fraser
>> 
>> _______________________________________________
>> Linux-PowerEdge mailing list
>> Linux-PowerEdge at dell.com
>> https://lists.us.dell.com/mailman/listinfo/linux-poweredge
>> Please read the FAQ at http://lists.us.dell.com/faq
>>  
> 




More information about the Linux-PowerEdge mailing list