suu 6.2 / centos 5.4

Stephan van Hienen stephan.van.hienen at thevalley.nl
Fri Feb 12 16:49:27 CST 2010


After a clean centos 5.4 x64 install on a PE1850 I tried to run suu update.
I first installed the compat libs :

yum install compat-libstdc++-33.i386 compat-libstdc++-296

And suu -u :

]# ./suu -u

------------------------------------------------
Welcome to the Dell OpenManage Server Update Utility.
Copyright (c) 2003-2009 Dell Inc. All Rights Reserved.
SUU Version: 2 .0 .0 .140 

SUU Log location: /var/log/dell/suu

                                      
                            
System is compliant with prerequisites
[Fatal Error] :-1:-1: Premature end of file.
                           
The System Update Utility failed.
Premature end of file.
exiting SUU application ...


>From the logfile :

<..>
FINE: com.dell.suu.util.SystemExec.exec(): after call, args [/tmp/suu/./bin/Linux/BundleApp -update -force -continueonfailure -preinstenv -path /var/log/dell/suu/-954220325/CUSTOM_BUNDLE_PE1850-LX-R210596.XML 
Feb 13, 2010 1:55:41 AM com.dell.suu.util.SULogger log
FINE: com.dell.suu.util.SystemExec.exec(): error output: libstdc++-libc6.2-2.so.3 is required to run the Bundle Applicator.  
Install the compat-libstdc++-296-2.96-132.7.2.i386.rpm RPM from RedHat.com or from the RedHat CD.
<..>

But a newer rpm is installed :

]# rpm -qa --qf "%{n}-%{v}-%{r}.%{arch}\n" |grep compat-libstdc  
compat-libstdc++-296-2.96-138.i386
compat-libstdc++-33-3.2.3-61.i386

]# locate -i libstdc++-libc6.2-2.so.3                            
/usr/lib/libstdc++-libc6.2-2.so.3

Any hints how to solve this ?


Stephan




More information about the Linux-PowerEdge mailing list