OMSA 6.2 install issues...

John Oliver joliver at john-oliver.net
Tue Feb 9 10:42:15 CST 2010


On Tue, Feb 09, 2010 at 12:24:54AM -0600, Eric Rostetter wrote:
> As some of you already know, there are some RPM dependency issues in
> OMSA 6.2 which can cause problems (notably the "no controllers found" error
> from the storage commands).  I've found a new (to me at least) wrinkle...
> 
> After installing it on 2 identical machines, one worked completely and
> the other worked except for the storage.  Seeking help via google, I found
> the above mentioned threads about dependencies but I had all the packages
> installed on both machines...
> 
> This bit me because I don't like to install all the packages, only the
> ones I want (no web server and such).  So I didn't do the srvadmin-all
> package, but rather did individual packages so I could install the least
> amount needed for my setup.
> 
> To cut to the chase, I found out that no only is it important that you
> install all the needed RPMS, but that the order in which you install them
> is also critical.  Doing an "rpm -qa --last | grep srvadmin" on the working
> machine, I got the order in which they were installed.  On the non-working
> machine, I removed all the packages and re-installed them in the same order
> as on the working machine.  Et voila, I have two working machines now...
> 
> Only took me a week to figure that one out...

So what's the correct order? :-)

-- 
***********************************************************************
* John Oliver                             http://www.john-oliver.net/ *
*                                                                     *
***********************************************************************



More information about the Linux-PowerEdge mailing list