OMSA yum repo failing to find needed packages

Malina Kirn m.a.kirn at gmail.com
Tue Aug 31 11:50:33 CDT 2010


Hi all,

I've been using OMSA successfully several years now and recently
changed to the Dell yum repository as my installation mechanism.  I
believe I've called yum update successfully several times, but this
time, yum can't seem to find the needed packages to satisfy
dependencies for OMSA:

srvadmin-standardAgent-6.2.0-1.5.el5.i386 from installed has depsolving problems
  --> Missing Dependency: srvadmin-cm = 6.2.0 is needed by package
srvadmin-standardAgent-6.2.0-1.5.el5.i386 (installed)
srvadmin-all-6.2.0-1.5.el5.i386 from installed has depsolving problems
  --> Missing Dependency: srvadmin-storageservices = 6.2.0 is needed
by package srvadmin-all-6.2.0-1.5.el5.i386 (installed)
srvadmin-base-6.2.0-1.5.el5.i386 from installed has depsolving problems
  --> Missing Dependency: srvadmin-cm = 6.2.0 is needed by package
srvadmin-base-6.2.0-1.5.el5.i386 (installed)
srvadmin-racadm5-6.2.0-677.i386 from installed has depsolving problems
  --> Missing Dependency: srvadmin-hapi = 6.2.0 is needed by package
srvadmin-racadm5-6.2.0-677.i386 (installed)
srvadmin-rac4-6.2.0-1.5.el5.i386 from installed has depsolving problems
  --> Missing Dependency: srvadmin-racdrsc4 = 6.2.0 is needed by
package srvadmin-rac4-6.2.0-1.5.el5.i386 (installed)
srvadmin-rac5-6.2.0-1.5.el5.i386 from installed has depsolving problems
  --> Missing Dependency: srvadmin-racdrsc5 = 6.2.0 is needed by
package srvadmin-rac5-6.2.0-1.5.el5.i386 (installed)
srvadmin-racadm4-6.2.0-677.i386 from installed has depsolving problems
  --> Missing Dependency: srvadmin-omilcore = 6.2.0 is needed by
package srvadmin-racadm4-6.2.0-677.i386 (installed)
srvadmin-racsvc-6.2.0-677.i386 from installed has depsolving problems
  --> Missing Dependency: srvadmin-omilcore = 6.2.0 is needed by
package srvadmin-racsvc-6.2.0-677.i386 (installed)
srvadmin-idracadm-6.2.0-677.i386 from installed has depsolving problems
  --> Missing Dependency: srvadmin-hapi = 6.2.0 is needed by package
srvadmin-idracadm-6.2.0-677.i386 (installed)
srvadmin-idrac-6.2.0-1.5.el5.i386 from installed has depsolving problems
  --> Missing Dependency: srvadmin-idracdrsc = 6.2.0 is needed by
package srvadmin-idrac-6.2.0-1.5.el5.i386 (installed)
Error: Missing Dependency: srvadmin-omilcore = 6.2.0 is needed by
package srvadmin-racsvc-6.2.0-677.i386 (installed)
Error: Missing Dependency: srvadmin-racdrsc5 = 6.2.0 is needed by
package srvadmin-rac5-6.2.0-1.5.el5.i386 (installed)
Error: Missing Dependency: srvadmin-hapi = 6.2.0 is needed by package
srvadmin-idracadm-6.2.0-677.i386 (installed)
Error: Missing Dependency: srvadmin-storageservices = 6.2.0 is needed
by package srvadmin-all-6.2.0-1.5.el5.i386 (installed)
Error: Missing Dependency: srvadmin-omilcore = 6.2.0 is needed by
package srvadmin-racadm4-6.2.0-677.i386 (installed)
Error: Missing Dependency: srvadmin-cm = 6.2.0 is needed by package
srvadmin-base-6.2.0-1.5.el5.i386 (installed)
Error: Missing Dependency: srvadmin-idracdrsc = 6.2.0 is needed by
package srvadmin-idrac-6.2.0-1.5.el5.i386 (installed)
Error: Missing Dependency: srvadmin-racdrsc4 = 6.2.0 is needed by
package srvadmin-rac4-6.2.0-1.5.el5.i386 (installed)
Error: Missing Dependency: srvadmin-cm = 6.2.0 is needed by package
srvadmin-standardAgent-6.2.0-1.5.el5.i386 (installed)
Error: Missing Dependency: srvadmin-hapi = 6.2.0 is needed by package
srvadmin-racadm5-6.2.0-677.i386 (installed)

I note that I'm still running OMSA 6.2 and that 6.3 is now released.
But yum upgrade srvadmin-all does nothing, nor can I call the
bootstrap script again.

Suggestions?

Thank you,
Malina Kirn



More information about the Linux-PowerEdge mailing list