OMSA yum install default to i386 for x86_64 servers, and the x86_64 OMSA not work for pe2950

Frank Wang wg at yarbs.cn
Tue Aug 24 23:13:21 CDT 2010


Hi,
    I built a local yum repo mirror of the OMSA a couple of month ago to
install/update my Dell servers' OMSA and it worked great until the
recent 6.3 upgrade. I noticed that one of my R710 failed, reporting
errors like following:
srvadmin-iws-6.3.0-184.1.el5.x86_64 conflicts with
srvadmin-omcommon-6.2.0-1.19.el5.i386
srvadmin-isvc-6.3.0-100.2.el5.x86_64 conflicts with
srvadmin-isvc-6.2.0-1.16.el5.i386
    The R710 was installed a Centos-5.5 x86_64. I didn't aware that my
working OMSA-6.2 was an i386 and had to completely remove it before
reinstall the default x86_64 one from my local repo,
yum remove srvadmin\*
yum install srvadmin\*
    And the OMSA-6.3 x86_64 works greatly for the R710 now.
    But the same doesn't work for the PE2950 which was also installed a
Centos 5.5 x86_64. I noticed that both i386 and x86_64 srvadmin-all
i386 were included and there were dependencies not met. So I altered
the second command like this and include office mirrorlist in my yum
repo settings,
yum install srvadmin\*x86_64
    Then, the i386 srvadmin-all was gone and the OMSA-6.3 x86_64 installed
finally, but it doesn't work. The dsm_sa_datamgrd, dsm_sa_eventmgrd
and dsm_sa_snmpd services can't be started no matter how. Don't know
where to check the log to identify the possible reason. Then I altered
my local repo settings to use the i386 one and OMSA is happy now. I
also tried the official repo with all the default settings, and it
always use the i386 OMSA instead of the x86_64 one as well.
    Why the i386 OMSA is the default for a x86_64 server? Is there
anything I did wrong at first place?
    Thanks!

Regards,
Frank Wang



More information about the Linux-PowerEdge mailing list