Firmware update error - 6.3 on R410 (CentOS 5.5)

Robin Bowes robin-lists at robinbowes.com
Thu Aug 5 10:54:24 CDT 2010


 Hi,

I've just updated to 6.3 from 6.2 and am trying to update firmware.

I get the error listed below.

Any ideas what the problem is?

R.

[root at b001 dell_dup]# update_firmware -y

Running system inventory...

Searching storage directory for available BIOS updates...
Checking BIOS - 1.1.5
    Available: dell_dup_componentid_00159 - 1.4.7
    Found Update: dell_dup_componentid_00159 - 1.4.7
Checking MBD2147RC Firmware - d606
    Available: dell_dup_componentid_20513 - d606
    Did not find a newer package to install that meets all installation
checks.
Checking NetXtreme II BCM5716 Gigabit Ethernet rev 20 (eth1) - 5.0.9
    Available: pci_firmware(ven_0x14e4_dev_0x163b) - 5.0.12
    Found Update: pci_firmware(ven_0x14e4_dev_0x163b) - 5.0.12
Checking NetXtreme II BCM5716 Gigabit Ethernet rev 20 (eth0) - 5.0.9
    Available: pci_firmware(ven_0x14e4_dev_0x163b) - 5.0.12
    Found Update: pci_firmware(ven_0x14e4_dev_0x163b) - 5.0.12
Checking SAS/SATA Backplane 0:0 Backplane Firmware - 1.07
    Available: dell_dup_componentid_11204 - 1.05
    Available: dell_dup_componentid_11204 - 1.07
    Did not find a newer package to install that meets all installation
checks.
Checking iDRAC6 - 1.41
    Did not find a newer package to install that meets all installation
checks.
Checking PERC 6/i Adapter Controller 0 Firmware - 6.2.0-0013
    Available:
pci_firmware(ven_0x1000_dev_0x0060_subven_0x1028_subdev_0x1f0b) - 6.2.0-0013
    Did not find a newer package to install that meets all installation
checks.
Checking System BIOS for PowerEdge R410 - 1.1.5
    Did not find a newer package to install that meets all installation
checks.

Found firmware which needs to be updated.

Running updates...
-    Installing dell_dup_componentid_00159 - 1.4.7Installation failed
for package: dell_dup_componentid_00159 - 1.4.7
aborting update...

The error message from the low-level command was:

Could not parse output, bad xml for package: dell_dup_componentid_00159

The last bit with --verbose is:

Running updates...
hey, we are supposed to be installing now... :)
/    Installing dell_dup_componentid_00159 - 1.4.7loading xml from:
/usr/libexec/dell_dup/BIOS_NONE/PIEConfig.xml
loaded.
    Plugin command is biosie.bin -u update.xml
    Output file is update.xml
    Plugin timeout is 600
/    Installing dell_dup_componentid_00159 - 1.4.7output from the cmd was:

-    Installing dell_dup_componentid_00159 - 1.4.7Could not parse
output, bad xml for package: dell_dup_componentid_00159
None
Installation failed for package: dell_dup_componentid_00159 - 1.4.7
aborting update...

The error message from the low-level command was:

Could not parse output, bad xml for package: dell_dup_componentid_00159

And the same thing with --trace:

hey, we are supposed to be installing now... :)
loading xml from: /usr/libexec/dell_dup/BIOS_NONE/PIEConfig.xml
loaded.
    Plugin command is biosie.bin -u update.xml
    Output file is update.xml
    Plugin timeout is 600
/    Installing dell_dup_componentid_00159 - 1.4.7output from the cmd was:

EXCEPTION: Could not parse output, bad xml for package:
dell_dup_componentid_00159
Traceback (most recent call last):
  File
"/usr/lib/python2.4/site-packages/firmwaretools/trace_decorator.py",
line 81, in trace
    result = func(*args, **kw)
  File
"/usr/lib/python2.4/site-packages/dell_ft_ie_interface/ie_interface.py",
line 146, in install
    raise ExecutionError(message)
ExecutionError: Could not parse output, bad xml for package:
dell_dup_componentid_00159
LEAVE install --> 'EXCEPTION RAISED'

LEAVE run --> None

-    Installing dell_dup_componentid_00159 - 1.4.7Could not parse
output, bad xml for package: dell_dup_componentid_00159
None
EXCEPTION: Could not parse output, bad xml for package:
dell_dup_componentid_00159
Traceback (most recent call last):
  File
"/usr/lib/python2.4/site-packages/firmwaretools/trace_decorator.py",
line 81, in trace
    result = func(*args, **kw)
  File "/usr/lib/python2.4/site-packages/firmwaretools/pycompat.py",
line 177, in runLongProcess
    raise thread.exception
ExecutionError: Could not parse output, bad xml for package:
dell_dup_componentid_00159
LEAVE runLongProcess --> 'EXCEPTION RAISED'

Installation failed for package: dell_dup_componentid_00159 - 1.4.7
aborting update...

The error message from the low-level command was:

Could not parse output, bad xml for package: dell_dup_componentid_00159
LEAVE updateFirmware --> None

LEAVE doCommand --> [0, 'Done']

LEAVE doCommands --> [0, 'Done']

Complete!
ENTER unlock(<cli.BaseCli object at 0x2b3d4ffbd710>, )
LEAVE unlock --> None

-- 
"Feed that ego and you starve the soul" - Colonel J.D. Wilkes
http://www.theshackshakers.com/



More information about the Linux-PowerEdge mailing list