update_firmware kickstart problem

Alexander Dupuy alex.dupuy at mac.com
Thu Apr 29 09:23:11 CDT 2010


Ali Tayarani writes:
> When I run update_firmware in a kickstart postscript, the updates claim to
> install, but after reboot the firmware hasn't changed. Yet, when I run the
> same commands from the CLI after first boot, the firmware updates and stays
> updated.

We install a number of firmware updates (using DUPs) from kickstart post 
script (RHEL 5), but for them to work (notably the BMC and iDRAC6 
firmware updates), I have found that we need to do the following:

* run the DUPs in the chrooted installation

    if your post script is --nochroot you need to explicitly chroot 
/mnt/sysimage

* start up certain drivers, notably IPMI - you also need to make sure 
that the Dell RPMs are installed too (we use the ones from the DTK, but 
you would probably be fine with the OMSA versions as well).

      # iDRAC firmware load needs access to iDRAC virtual USB device as 
/dev/sdX
      /sbin/start_udev

      # many syscfg options require /dev/ipmi0 - BMC/iDRAC DUPs do too
      /etc/init.d/ipmi start
      /etc/init.d/instsvcdrv start

* wait for PERC RAID background initialization to complete before 
applying drive firmware updates

I hope that you find this helpful, and that you can apply it to the 
update_firmware RPM-based approach.

@alex

-- 
mailto:alex.dupuy at mac.com



More information about the Linux-PowerEdge mailing list