SNMP monitoring of PERC H200 via MSM

Monty unclemonty at gmail.com
Wed Apr 28 07:19:53 CDT 2010


Has anyone managed to successfully SNMP poll controller/unit/disk
information from Linux hosts running PERC H200 and MegaRAID Storage
Manager (lsi_mrdsnmpagent component)?

I'm seeing a valid SNMP response with some system information, but
nothing about the card or array.

MSM server part appears to work and the controller/unit/disks can be
seen and managed just fine from the MSM Client.

Thanks.

SNMP Output:

LSI-MegaRAID-SAS-MIB::hostName.0 = STRING: "hostname"
LSI-MegaRAID-SAS-MIB::hostOSInfo.0 = STRING: "CentOS release 5.4 (Final)"
LSI-MegaRAID-SAS-MIB::mibVersion.0 = STRING: "1.24-07"
LSI-MegaRAID-SAS-MIB::agentModuleName.0 = STRING: "lsi_mrdsnmpagent"
LSI-MegaRAID-SAS-MIB::agentModuleVersion.0 = STRING: "3.17.0.1"
LSI-MegaRAID-SAS-MIB::releaseDate.0 = STRING: "03rd Nov 2009"
LSI-MegaRAID-SAS-MIB::adpNumber.0 = Wrong Type (should be Gauge32 or
Unsigned32): INTEGER: 0
LSI-MegaRAID-SAS-MIB::bbuNumber.0 = Wrong Type (should be Gauge32 or
Unsigned32): INTEGER: 0
LSI-MegaRAID-SAS-MIB::pdNumber.0 = Wrong Type (should be Gauge32 or
Unsigned32): INTEGER: 0
LSI-MegaRAID-SAS-MIB::vdNumbers.0 = Wrong Type (should be Gauge32 or
Unsigned32): INTEGER: 0
LSI-MegaRAID-SAS-MIB::arrayNumber.0 = Wrong Type (should be Gauge32 or
Unsigned32): INTEGER: 0
LSI-MegaRAID-SAS-MIB::spareDevNumber.0 = Wrong Type (should be Gauge32
or Unsigned32): INTEGER: 0
LSI-MegaRAID-SAS-MIB::enclosureNumber.0 = Wrong Type (should be
Gauge32 or Unsigned32): INTEGER: 0
LSI-MegaRAID-SAS-MIB::copyright.0 = STRING: "LSI Corporation"



More information about the Linux-PowerEdge mailing list