***POSSIBLE SOLUTION*** OM 6.2 Broken Storage Section

Sijis Aviles saviles at empire-today.com
Fri Apr 16 17:53:47 CDT 2010


I wasn't able to find if there was a resolution to this, so I'll post
what worked for me.

I installed 6.2 on a 2950 as noted in
http://linux.dell.com/repo/hardware/OMSA_6.2/

When I started the services
# srvadmin-services.sh start

I got an error like this "Error while loading shared libraries:
libstdc++.so.5" but the service was showing at started. After doing some
digging, I found this readme (http://ftp.dell.com/diags/DR5125A0.txt)
which noted to install the compatibility librairies.

# yum install compat-libstdc++-33 (the one thing not mentioned)

Once I did that, storage started to work just fine.

I hope this helps someone.

Sijis

-----Original Message-----

Message: 2
Date: Fri, 18 Dec 2009 14:54:12 -0500
From: Ryan Miller <rmiller at smartertravelmedia.com>
Subject: RE: ***POSSIBLE SOLUTION*** OM 6.2 Broken Storage Section 
To: "Jeffrey_L_Mendoza at Dell.com" <Jeffrey_L_Mendoza at Dell.com>,
	"linux-poweredge at lists.us.dell.com"
	<linux-poweredge at lists.us.dell.com>
Message-ID:
	
<BCE8FBE2CEE56C46AF5976DEAB50361758692A7610 at QUINCY.smartertravelmedia.co
m>
	
Content-Type: text/plain; charset="us-ascii"

Turns out that the reason that srvadmin-all wouldn't install after just
editing the .repo file to say OMSA_6.1 instead of latest and the failure
of update_firmware were related:  something strange with dependency
resolution around libsmbios means that for things to work I need to
remove that package before upgrading or downgrading; seems like a
specific version of python-smbios is required, but I'm able to downgrade
srvadmin* without yum throwing a conflict or dependency.  Not sure
what's wrong with the dependency graph or how to give you more useful
information, but at least now I have a way back onto 6.1, and
update_firmware now works with 6.2.

Still not seeing the disk controllers under 6.2 no matter what I do
though, for SAS or PERC6, on 1950-III or R610.

Hope that's at least moderately helpful, and let me know if there's some
way I can provide better information.

Ryan

From: Jeffrey_L_Mendoza at Dell.com [mailto:Jeffrey_L_Mendoza at Dell.com]
Sent: Friday, December 18, 2009 12:12 PM
To: Ryan Miller; linux-poweredge at lists.us.dell.com
Subject: RE: ***POSSIBLE SOLUTION*** OM 6.2 Broken Storage Section

Ryan,

Thanks for the report on the firmware update exception. What
distro/version are you running? Would you mind posting the output with
'--verbose'?

Thanks,
Jeff

________________________________
From: linux-poweredge-bounces-Lists On Behalf Of Ryan Miller
Sent: Thursday, December 17, 2009 7:03 PM
To: linux-poweredge-Lists
Subject: ***POSSIBLE SOLUTION*** OM 6.2 Broken Storage Section
I'm also seeing this issue, and no luck with the workaround either.
(Plus I had to manually unload the ipmi module-stopping the service
didn't do it).    I opened a support case and he tried suggested to use
the driver from the website - v00.00.03.21 instead of the 00.00.04.08 in
the 2.6.18-164.6.1.el5 kernel, but as this kernel and hardware play fine
with OMSA6.1 I didn't really want to go that direction (and doubt it
would help anyway).

Also, firmware updates seem to be broken:

[root at write1y ~]# update_firmware --yes

Running system inventory...

Searching storage directory for available BIOS updates...
Checking BIOS - 1.2.6
        Available: dell_dup_componentid_00159 - 1.3.6
        Found Update: dell_dup_componentid_00159 - 1.3.6
Checking MBE2147RC Firmware - d701
        Available: dell_dup_componentid_20515 - d903
        Found Update: dell_dup_componentid_20515 - d903
Checking SAS/SATA Backplane 0:0 Backplane Firmware - 1.07
        Available: dell_dup_componentid_11204 - 1.05
        Did not find a newer package to install that meets all
installation checks.
Checking PERC 6/i Integrated Controller 0 Firmware - 6.2.0-0013
        Available:
pci_firmware(ven_0x1000_dev_0x0060_subven_0x1028_subdev_0x1f0c) -
6.2.0-0013
        Did not find a newer package to install that meets all
installation checks.
Checking System BIOS for PowerEdge R610 - 1.2.6
        Did not find a newer package to install that meets all
installation checks.

Found firmware which needs to be updated.

Running updates...
|       Installing dell_dup_componentid_00159 - 1.3.6Traceback (most
recent call last):
  File "/usr/sbin/update_firmware", line 23, in ?
    ftmain.main(sys.argv[1:])
  File "/usr/share/firmware-tools/ftmain.py", line 109, in main
    result, resultmsgs = base.doCommands()
  File "<firmwaretools.peak_util_decorators.rewrap wrapping
cli.doCommands at 0x2ABEB180B230>", line 3, in doCommands
  File
"/usr/lib/python2.4/site-packages/firmwaretools/trace_decorator.py",
line 81, in trace
    result = func(*args, **kw)
  File "/usr/share/firmware-tools/cli.py", line 134, in doCommands
    self.opts.mode, self.fullCmdLine, self.args)
  File "<firmwaretools.peak_util_decorators.rewrap wrapping
update_cmd.doCommand at 0x2ABEB2151C80>", line 3, in doCommand
  File
"/usr/lib/python2.4/site-packages/firmwaretools/trace_decorator.py",
line 81, in trace
    result = func(*args, **kw)
  File "/usr/share/firmware-tools/plugins/update_cmd.py", line 61, in
doCommand
    base.updateFirmware(base.opts.show_unknown)
  File "<firmwaretools.peak_util_decorators.rewrap wrapping
cli.updateFirmware at 0x2ABEB180BAA0>", line 3, in updateFirmware
  File
"/usr/lib/python2.4/site-packages/firmwaretools/trace_decorator.py",
line 81, in trace
    result = func(*args, **kw)
  File "/usr/share/firmware-tools/cli.py", line 214, in updateFirmware
    ret = firmwaretools.pycompat.runLongProcess(pkg.install,
waitLoopFunction=statusFunc)
  File "<firmwaretools.peak_util_decorators.rewrap wrapping
firmwaretools.pycompat.runLongProcess at 0x2ABEB0EEFAA0>", line 3, in
runLongProcess
  File
"/usr/lib/python2.4/site-packages/firmwaretools/trace_decorator.py",
line 81, in trace
    result = func(*args, **kw)
  File "/usr/lib/python2.4/site-packages/firmwaretools/pycompat.py",
line 177, in runLongProcess
    raise thread.exception
xml.parsers.expat.ExpatError: no element found: line 1, column 0

Haven't dug through the python to see what the source of that might be
yet, but it certainly works for me with OMSA6.1.

Does anyone know what incantation I can substitute in the .repo file for

mirrorlist=http://linux.dell.com/repo/hardware/latest/mirrors.cgi?osname
=el$releasever&basearch=$basearch&dellsysidpluginver=$dellsysidpluginver

to stay on 6.1?  Merely swapping 6.1 in for "latest" doesn't work for
whatever reason.

Thanks,

Ryan







-------------- next part --------------
An HTML attachment was scrubbed...
URL:
http://lists.us.dell.com/pipermail/linux-poweredge/attachments/20091218/
c22ed4b5/attachment.htm 

------------------------------

_______________________________________________
Linux-PowerEdge mailing list
Linux-PowerEdge at dell.com
https://lists.us.dell.com/mailman/listinfo/linux-poweredge
Please read the FAQ at http://lists.us.dell.com/faq

End of Linux-PowerEdge Digest, Vol 65, Issue 34
***********************************************
Connect with us online - Facebook: www.facebook.com/empiretoday   Twitter: www.twitter.com/empiretoday

                        
The information contained in this message may be confidential and is for the intended addressee only.
Any unauthorized use, dissemination of the information, or copying of this message is prohibited. 
If you are not the intended addressee, please notify the sender immediately and delete this message.





More information about the Linux-PowerEdge mailing list