Centos Update 1950 wont boot 2.6.18-164.11.1.el5

Steve Tempest Steve.Tempest at gts.apn.com.au
Thu Apr 15 18:00:39 CDT 2010


Hi,

Have you installed the sas drivers from the dell linux repo?

I did that and it broke the initrd....

I think this may contribute to the problem.

Cheers

Steve.

-----Original Message-----
From: linux-poweredge-bounces at dell.com [mailto:linux-poweredge-bounces at dell.com] On Behalf Of Todd Lyons
Sent: Friday, 16 April 2010 1:34 AM
To: J. Epperson
Cc: linux-poweredge at dell.com
Subject: Re: Centos Update 1950 wont boot 2.6.18-164.11.1.el5

On Tue, Mar 2, 2010 at 7:55 PM, J. Epperson <Dell at epperson.homelinux.net> wrote:
>>
>> I took your advice and tried recreating the initrd without any success.
>> I ended out performing the upgrade on another server with identical
>> hardware and copying the boot files over from it and that has sorted out
>> my problem.

I have a CentOS 5.4 instance for our TEST sytem that runs in a VM.  I
just finished migrating it back to a real server because performance
was so miserable that it was unusable.  How miserable? 6 minute apache
restarts now take ~ 20 seconds, the same as our LIVE system.

My 1950 has a PERC 5 in it, so the hardware is slightly different, but
the symptoms are the same:  In rescue mode, I could not get mkinitrd
to make an initrd that it would mount the root filesystem under
2.6.18-164.11.1.el5.  I have another identical machine, so I copied
the initrd from an older kernel (2.6.18-164.el5) and it booted right
up.

> Sorry the hunch didn't work out for you, glad you found a path out of the
> darkness.  Apparently something else in the install/postinstall of that
> kernel broke.  Good chance that removing and reinstalling the new kernel
> rpm would also have fixed it.  But that's another hunch, and I'm 0-1 with

I didn't think of that one.  When I get a maintenance window, I will
do some more testing to see if the other installed kernels exhibit the
same behavior.  I will be testing:
2.6.18-164.1.6.el5
2.6.18-164.2.1.el5

But first I will remove, remove all traces of, and then reinstall
2.6.18-164.11.1.el5 and see if there is any difference, as per your
suggestion.

-- 
Regards...      Todd
I seek the truth...it is only persistence in self-delusion and
ignorance that does harm.  -- Marcus Aurealius

_______________________________________________
Linux-PowerEdge mailing list
Linux-PowerEdge at dell.com
https://lists.us.dell.com/mailman/listinfo/linux-poweredge
Please read the FAQ at http://lists.us.dell.com/faq

Notice

 

This email and any attachments are strictly confidential and subject to copyright.  They may
contain privileged information.  If you are not the intended recipient please delete the message 
and notify the sender. You should not read, copy, use, change, alter or disclose this email or 
its attachments without authorisation.  The company and any related or associated companies do 
not accept any liability in connection with this email and any attachments including in connection 
with computer viruses, data corruption, delay, interruption, unauthorised access or unauthorised 
amendment. Any views expressed in this email and any attachments do not necessarily reflect the 
views of the company or the views of any of our related or associated companies.





More information about the Linux-PowerEdge mailing list