Centos Update 1950 wont boot 2.6.18-164.11.1.el5

Todd Lyons tlyons at ivenue.com
Thu Apr 15 10:33:53 CDT 2010


On Tue, Mar 2, 2010 at 7:55 PM, J. Epperson <Dell at epperson.homelinux.net> wrote:
>>
>> I took your advice and tried recreating the initrd without any success.
>> I ended out performing the upgrade on another server with identical
>> hardware and copying the boot files over from it and that has sorted out
>> my problem.

I have a CentOS 5.4 instance for our TEST sytem that runs in a VM.  I
just finished migrating it back to a real server because performance
was so miserable that it was unusable.  How miserable? 6 minute apache
restarts now take ~ 20 seconds, the same as our LIVE system.

My 1950 has a PERC 5 in it, so the hardware is slightly different, but
the symptoms are the same:  In rescue mode, I could not get mkinitrd
to make an initrd that it would mount the root filesystem under
2.6.18-164.11.1.el5.  I have another identical machine, so I copied
the initrd from an older kernel (2.6.18-164.el5) and it booted right
up.

> Sorry the hunch didn't work out for you, glad you found a path out of the
> darkness.  Apparently something else in the install/postinstall of that
> kernel broke.  Good chance that removing and reinstalling the new kernel
> rpm would also have fixed it.  But that's another hunch, and I'm 0-1 with

I didn't think of that one.  When I get a maintenance window, I will
do some more testing to see if the other installed kernels exhibit the
same behavior.  I will be testing:
2.6.18-164.1.6.el5
2.6.18-164.2.1.el5

But first I will remove, remove all traces of, and then reinstall
2.6.18-164.11.1.el5 and see if there is any difference, as per your
suggestion.

-- 
Regards...      Todd
I seek the truth...it is only persistence in self-delusion and
ignorance that does harm.  -- Marcus Aurealius



More information about the Linux-PowerEdge mailing list