OMSA 6.2 dsm_sa_datamgrd not starting

Eelco Leenen eelco.leenen at care.nl
Wed Apr 7 04:59:31 CDT 2010


Hello,

 

I have freshly installed a  Poweredge R300 with Redhat Enterprise 5. I
installed OMSA 6.2 on this machine using the yum repository and
initially it worked fine. 

 

When I saw a warning in the OMSA interface that my SAS 6iR driver was
out of date, I downloaded the latest version from the Dell support site
(which is 4.00.38.02-3.A03 at this moment) and installed the included
RPM packages. This is where the trouble began.

 

Now, I cannot get OMSA to work properly anymore. The service
'dsm_sa_datamgrd' takes minutes when I want to start the services and I
will eventually fail:

 

[root at server sbin]# ./srvadmin-services.sh start

Starting Systems Management Device Drivers:

Starting dell_rbu:                                         [  OK  ]

Starting ipmi driver:                                      [  OK  ]

Starting Systems Management Data Engine:

Starting dsm_sa_datamgrd:                                  [FAILED]

Starting dsm_sa_eventmgrd:                                 [  OK  ]

Starting dsm_sa_snmpd:                                     [  OK  ]

Starting DSM SA Shared Services:                           [  OK  ]

Starting DSM SA Connection Service:                        [  OK  ]

[root at server sbin]#

 

Strangely, when I do a status check it says that all services are
running:

 

[root at server sbin]# ./srvadmin-services.sh status

dell_rbu (module) is running

ipmi driver is running

dsm_sa_datamgrd (pid 19802) is running

dsm_sa_eventmgrd (pid 20036) is running

dsm_sa_snmpd (pid 20095) is running

dsm_om_shrsvcd (pid 20167) is running...

dsm_om_connsvcd (pid  20219) is running...

[root at server sbin]#

 

The webinterface is not available however. I tried to revert my steps by
uninstalling the SAS driver and even reinstall all srvadmin packages but
that didn't work. I still have the same problem.

 

Does anybody know where the problem may come from? Or maybe there is a
way that I can get more information regarding the source of the problem
from logfiles, as far as I know there aren't any that can help.

 

Thanks!

 

--

Eelco

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.us.dell.com/pipermail/linux-poweredge/attachments/20100407/e9bab23b/attachment.htm 


More information about the Linux-PowerEdge mailing list