Linux Debian 5 on PE R610 : random freeze at boot

Stephen Dowdy sdowdy at
Wed Sep 16 11:10:27 CDT 2009


We're running Lenny on several R610/R710 systems here.  We got them
before BIOS 1.1.4 (was 1.0.4) and had lots of grief.  several systems
were installed 32-bit because, while the e820 BIOS memory probe stuff
was broken (in BIOS 1.0.4), we could at least boot the systems in
32-bit, but not 64-bit.  (albeit with only 1GB of the RAM being
configured :-( )

Now that 1.1.4 is out we still have some less major issues and have
a few installed with amd64.

We disable the hpet timer because it locks up the machine sometimes
for extended periods.  (you'll see lines like:
    CE: hpet increasing min_delta_ns to 15000 nsec
in 'dmesg' output)

Here's a script to disable the HPET timer:
sed -i-`date +%Y%m%d%H%M`.bak -e '/^#[[:space:]]*.*hpet=/,$b;s/^\(#[[:space:]]*kopt=.*$\)/\1 hpet=disable/' ${grub_menu}

Here's another sed script to enable the rootdelay option programmatically, too:
sed -i-`date +%Y%m%d%H%M`.bak -e '/^#[[:space:]]*kopt=.*rootdelay=/,$b;s/^\(#[[:space:]]*kopt=.*$\)/\1 rootdelay=10/' ${grub_menu}
(these scripts only check if you have specified an hpet or rootdelay option,
and assume if you have you know what you're doing, otherwise, they change
it to use hpet=disable or rootdelay=10)

and i'm still not convinced that BIOS 1.2.6 kit for R610 is good.
It appears to have a PowerEdge R710 BIOS payload in it.  That may
be all well/good (the image may be the same), but i'm certainly
not comforted by the filename, nor the fact that only "PowerEdge R710"
as a string exists in the file, but not R610.

I have a support call into Dell over this,
and after 2 weeks, still no answer (though frontline support has
been quick to respond, as well as my program manager)

pick:R610# wget
pick:R610# sh PER610_BIOS_LX_1.2.6.BIN --extract FOO
pick:R610# ls -l FOO/payload
total 4104
-rwxr-xr-t 1 root root 4194396 2009-07-17 11:57 r710-010206.hdr*

Say, wha!?!  'r710*', instead of R610 hdr.

pick:payload# strings - * | grep 610
pick:payload# strings - * | grep 710
Dell System PowerEdge R710

So, i'm leery to apply/attempt this BIOS update myself until i
hear affirmatively that Dell believes this is the correct setup.

>From your last message, it seems to indicate that the
system is up, but "crashing", (so presumably rootdelay=
fixed your random boot failures?)

Anyway, hope this helps a bit.


More information about the Linux-PowerEdge mailing list