Installing OMSA 6.1 on R710 running Oracle VM Server 2.1.5

Robert Parker Robert.Parker at LCRA.ORG
Wed Sep 9 14:06:06 CDT 2009


I'm having trouble installing OMSA 6.1 using the described method.  I'm installing on Dell R710s running Oracle VM Server 2.1.5 (which should essentially be the same as RHEL 5).  When I try to install I get the following error:

[root at ovmxnpl03s ovs-agent]# wget -q -O - http://linux.dell.com/repo/hardware/latest/bootstrap.cgi | bash
Downloading GPG key: http://linux.dell.com/repo/hardware/latest/RPM-GPG-KEY-dell
    Importing key into RPM.
Downloading GPG key: http://linux.dell.com/repo/hardware/latest/RPM-GPG-KEY-libsmbios
    Importing key into RPM.
Write repository configuration
Downloading repository RPM
Installing repository rpm: http://linux.dell.com/repo/hardware/latest/platform_independent/rh50/prereq/dell-omsa-repository-2-5.noarch.rpm
Installing yum plugins for system id
Loading "installonlyn" plugin
Setting up Install Process
Setting up repositories
dell-omsa-specific        100% |=========================| 1.9 kB    00:00
dell-omsa-indep           100% |=========================| 1.9 kB    00:00
Reading repository metadata in from local files
primary.xml.gz            100% |=========================| 7.9 kB    00:00
################################################## 24/24
primary.xml.gz            100% |=========================| 7.9 kB    00:00
################################################## 24/24
Parsing package install arguments
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Downloading header for yum-dellsysid to pack into transaction set.
yum-dellsysid-2.2.17-3.1. 100% |=========================| 7.9 kB    00:00
---> Package yum-dellsysid.i386 0:2.2.17-3.1.el5 set to be updated
--> Running transaction check
--> Processing Dependency: smbios-utils-python = 0:2.2.17-3.1.el5 for package: yum-dellsysid
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Downloading header for smbios-utils-python to pack into transaction set.
smbios-utils-python-2.2.1 100% |=========================|  10 kB    00:00
---> Package smbios-utils-python.i386 0:2.2.17-3.1.el5 set to be updated
--> Running transaction check
--> Processing Dependency: python-smbios = 2.2.17-3.1.el5 for package: smbios-utils-python
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Downloading header for python-smbios to pack into transaction set.
python-smbios-2.2.17-3.1. 100% |=========================|  12 kB    00:00
---> Package python-smbios.i386 0:2.2.17-3.1.el5 set to be updated
--> Running transaction check
--> Processing Dependency: libsmbios = 0:2.2.17-3.1.el5 for package: python-smbios
--> Processing Dependency: python-ctypes for package: python-smbios
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Downloading header for python-ctypes to pack into transaction set.
python-ctypes-1.0.2-1.2.e 100% |=========================| 7.0 kB    00:00
---> Package python-ctypes.i386 0:1.0.2-1.2.el5 set to be updated
---> Downloading header for libsmbios to pack into transaction set.
libsmbios-2.2.17-3.1.el5. 100% |=========================|  10 kB    00:00
---> Package libsmbios.i386 0:2.2.17-3.1.el5 set to be updated
--> Running transaction check

Dependencies Resolved

=============================================================================
 Package                 Arch       Version          Repository        Size
=============================================================================
Installing:
 yum-dellsysid           i386       2.2.17-3.1.el5   dell-omsa-specific   15 k
Installing for dependencies:
 libsmbios               i386       2.2.17-3.1.el5   dell-omsa-specific  1.5 M
 python-ctypes           i386       1.0.2-1.2.el5    dell-omsa-specific  210 k
 python-smbios           i386       2.2.17-3.1.el5   dell-omsa-specific   69 k
 smbios-utils-python     i386       2.2.17-3.1.el5   dell-omsa-specific   56 k

Transaction Summary
=============================================================================
Install      5 Package(s)
Update       0 Package(s)
Remove       0 Package(s)

Total download size: 1.8 M
Downloading Packages:
(1/5): python-smbios-2.2. 100% |=========================|  69 kB    00:00
(2/5): python-ctypes-1.0. 100% |=========================| 210 kB    00:00
(3/5): smbios-utils-pytho 100% |=========================|  56 kB    00:00
(4/5): yum-dellsysid-2.2. 100% |=========================|  15 kB    00:00
(5/5): libsmbios-2.2.17-3 100% |=========================| 1.5 MB    00:03
Running Transaction Test
Finished Transaction Test
Transaction Test Succeeded
Running Transaction
  Installing: libsmbios                    ######################### [1/5]
  Installing: python-ctypes                ######################### [2/5]
  Installing: python-smbios                ######################### [3/5]
  Installing: smbios-utils-python          ######################### [4/5]
  Installing: yum-dellsysid                ######################### [5/5]

Installed: yum-dellsysid.i386 0:2.2.17-3.1.el5
Dependency Installed: libsmbios.i386 0:2.2.17-3.1.el5 python-ctypes.i386 0:1.0.2-1.2.el5 python-smbios.i386 0:2.2.17-3.1.el5 smbios-utils-python.i386 0:2.2.17-3.1.el5
Complete!
Loading "installonlyn" plugin
Loading "dellsysid" plugin
usage: yum [options] < grouplist, localinstall, groupinfo, localupdate, resolvedep, erase, deplist, groupremove, makecache, upgrade, provides, shell, install, whatprovides, groupinstall, update, groupupdate, info, search, check-update, list, remove, clean, grouperase >

Command line error: no such option: --disableplugin

This can't be because the yum version is too old:

[root at ovmxnpl03s yum.repos.d]# rpm -qa | grep yum
yum-metadata-parser-1.0-8.fc6
yum-dellsysid-2.2.17-3.1.el5
yum-3.0.1-5.el5

So what else could it be?

Thanks,
Robert
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.us.dell.com/pipermail/linux-poweredge/attachments/20090909/070fe6fd/attachment-0001.htm 


More information about the Linux-PowerEdge mailing list