OMSA 5.5 on Ubuntu 8.10 (AMD64) XML Transformation Error

Gene Tang gene.tang at kiwiplan.co.nz
Tue Mar 17 17:55:47 CDT 2009


Hi,


Currently we have a PowerEdge 1950 running 8.10 Server 64 Bit (with PERC6/i integrated).  We have downloaded dellomsa_5.5.0-4.deb from ftp://ftp.sara.nl/pub/sara-omsa/dists/dell/sara/binary-amd64 and followed the howto from http://www.goingwip.de/index.php/projects/59-howtos/79-howto-ubuntu-server-debian-and-dell-raid-monitoring-over-omsa.



I am having two problems with OMSA on this server.



1)  Cannot log into the webinterface despite following the above guide and replacing the appropriate libraries in the /lib32, /lib32/security and updating the omauth file.  This same process worked on another ubuntu 8.04 server 64bit on a PowerEdge 2950.  I have double checked and reextracted the libraries, again to no avail.

2)  While performing nagios checks I am getting XML "Error Transformation Failed" errors when trying to get information about the physical disks (running "omreport storage pdisk controller=0").  This following is the error I am receiving:



Entity: line 21: parser error : CharRef: invalid decimal value

<Vendor type="astring">DELL&#-103;   </Vendor>

                             ^

Entity: line 21: parser error : xmlParseCharRef: invalid xmlChar value 0

<Vendor type="astring">DELL&#-103;   </Vendor>

                             ^

Entity: line 61: parser error : CharRef: invalid decimal value

<Vendor type="astring">DELL&#-103;   </Vendor>

                             ^

Entity: line 61: parser error : xmlParseCharRef: invalid xmlChar value 0

<Vendor type="astring">DELL&#-103;   </Vendor>

                             ^

Entity: line 101: parser error : CharRef: invalid decimal value

<Vendor type="astring">DELL&#-103;   </Vendor>

                             ^

Entity: line 101: parser error : xmlParseCharRef: invalid xmlChar value 0

<Vendor type="astring">DELL&#-103;   </Vendor>

                             ^

Entity: line 141: parser error : CharRef: invalid decimal value

<Vendor type="astring">DELL&#-103;   </Vendor>

                             ^

Entity: line 141: parser error : xmlParseCharRef: invalid xmlChar value 0

<Vendor type="astring">DELL&#-103;   </Vendor>

                             ^

Entity: line 21: parser error : CharRef: invalid decimal value

<Vendor type="astring">DELL&#-103;   </Vendor>

                             ^

Entity: line 21: parser error : xmlParseCharRef: invalid xmlChar value 0

<Vendor type="astring">DELL&#-103;   </Vendor>

                             ^

Entity: line 61: parser error : CharRef: invalid decimal value

<Vendor type="astring">DELL&#-103;   </Vendor>

                             ^

Entity: line 61: parser error : xmlParseCharRef: invalid xmlChar value 0

<Vendor type="astring">DELL&#-103;   </Vendor>

                             ^

Entity: line 101: parser error : CharRef: invalid decimal value

<Vendor type="astring">DELL&#-103;   </Vendor>

                             ^

Entity: line 101: parser error : xmlParseCharRef: invalid xmlChar value 0

<Vendor type="astring">DELL&#-103;   </Vendor>

                             ^

Entity: line 141: parser error : CharRef: invalid decimal value

<Vendor type="astring">DELL&#-103;   </Vendor>

                             ^

Entity: line 141: parser error : xmlParseCharRef: invalid xmlChar value 0

<Vendor type="astring">DELL&#-103;   </Vendor>

                             ^

Entity: line 21: parser error : CharRef: invalid decimal value

<Vendor type="astring">DELL&#-103;   </Vendor>

                             ^

Entity: line 21: parser error : xmlParseCharRef: invalid xmlChar value 0

<Vendor type="astring">DELL&#-103;   </Vendor>

                             ^

Entity: line 61: parser error : CharRef: invalid decimal value

<Vendor type="astring">DELL&#-103;   </Vendor>

                             ^

Entity: line 61: parser error : xmlParseCharRef: invalid xmlChar value 0

<Vendor type="astring">DELL&#-103;   </Vendor>

                             ^

Entity: line 101: parser error : CharRef: invalid decimal value

<Vendor type="astring">DELL&#-103;   </Vendor>

                             ^

Entity: line 101: parser error : xmlParseCharRef: invalid xmlChar value 0

<Vendor type="astring">DELL&#-103;   </Vendor>

                             ^

Entity: line 141: parser error : CharRef: invalid decimal value

<Vendor type="astring">DELL&#-103;   </Vendor>

                             ^

Entity: line 141: parser error : xmlParseCharRef: invalid xmlChar value 0

<Vendor type="astring">DELL&#-103;   </Vendor>

                             ^

Error! XML Transformation failed

I am unable to find any errors or log files to find out detailed reasons for this failure.  I am unsure if these issues are related as I have no detailed information.  Any pointers would be greatly appreciated.

Regards,

Gene
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.us.dell.com/pipermail/linux-poweredge/attachments/20090317/bac39f06/attachment.htm 


More information about the Linux-PowerEdge mailing list