OMSA package dependencies?

Jeff jlar310 at gmail.com
Mon Mar 16 10:39:18 CDT 2009


On Mon, Mar 16, 2009 at 8:42 AM,  <christian.peper at kpn.com> wrote:
>> -----Original Message-----
>> From: Matt Domsch [mailto:Matt_Domsch at dell.com]
>> Sent: Monday, March 16, 2009 2:07 PM
>> To: Peper, J.C.A. (Christian) (IT I&O System Engineering)
>> Cc: linux-poweredge at dell.com
>> Subject: Re: OMSA package dependencies?
>>
>> On Mon, Mar 16, 2009 at 12:53:44PM +0100,
>> christian.peper at kpn.com wrote:
>> > Hi all,
>> >
>> > However, I'm busy configuring a new Linux baseline for RHEL 5.3 and
>> > trying to minimize the packages that I install. So I'm not using a
>> > default package list but rather a heavily tuned list of packages.
>>
>> If you're not using kickstart %packages or yum to handle the
>> dependency resolution for you, then you're a masochist. :-)
>
> I do use kickstart and %packages to start with, but I start *very*
> minimally. The dependencies inside kickstart get me a ton of things that
> I'd rather not have. So I explicitely install those during a post
> install phase or remove a slew of packages that got bundled into the
> installation from kickstart. :)
>
>> Over the RPMs that are in srvadmin/ for OMSA 5.5 on a PE2950,
>> $ for f in *.rpm; do rpm -qp --requires $f >>
>> /tmp/requires1.txt; done $ sort /tmp/requires1.txt | uniq
>>
>> /bin/bash
>> /bin/sh
>> kernel >= 2.2.14
>> libclpsup32.so.3
>> libc.so.6
>> libc.so.6(GLIBC_2.0)
>> libc.so.6(GLIBC_2.1)
>> libc.so.6(GLIBC_2.1.3)
>> libc.so.6(GLIBC_2.2)
>> libc.so.6(GLIBC_2.2.4)
>> libc.so.6(GLIBC_2.3)
>> libdcecfl32.so.5
>> libdchbas32.so.5
>> libdchipm32.so.5
>> libdcsdrs32.so
>> libdcsdrs32.so.3
>> libdcsgen32.so.5
>> libdcship32.so.5
>> libdcsmil32.so.5
>> libdcsupt32.so.5
>> libdevent32.so.3
>> libdl.so.2
>> libdl.so.2(GLIBC_2.0)
>> libdl.so.2(GLIBC_2.1)
>> libdnet32.so.1
>> libdsupt32.so.1
>> libdweb32.so.1
>> libgcc_s.so.1
>> libgcc_s.so.1(GCC_3.0)
>> libgcc_s.so.1(GLIBC_2.0)
>> libm.so.6
>> libm.so.6(GLIBC_2.0)
>> libncurses.so.5
>> libomacs32.so.1
>> libomadb32.so.3
>> libomcldb32.so.3
>> libomclpr32.so.3
>> libomintf32.so.3
>> libomsas32.so.3
>> libpam.so.0
>> libpthread.so.0
>> libpthread.so.0(GLIBC_2.0)
>> libpthread.so.0(GLIBC_2.1)
>> libpthread.so.0(GLIBC_2.2)
>> libpthread.so.0(GLIBC_2.3.2)
>> librac.so
>> librac.so.1
>> libstdc++-libc6.2-2.so.3
>> libstdc++.so.5
>> libstdc++.so.5(GLIBCPP_3.2)
>> libstdc++.so.5(GLIBCPP_3.2.2)
>> libxml2.so.2
>> libxmlsup32.so.2
>> libz.so.1
>> openssl >= 0.9.6b
>> pam >= 0.59
>> pciutils
>> ppp >= 2.3.11
>> rpm >= 4.0.4
>> rpmlib(CompressedFileNames) <= 3.0.4-1
>> rpmlib(PayloadFilesHavePrefix) <= 4.0-1
>> rpmlib(VersionedDependencies) <= 3.0.3-1 setserial
>> srvadmin-deng srvadmin-deng = 5.5.0 srvadmin-hapi
>> srvadmin-hapi = 5.5.0 srvadmin-ipmi = 5.5.0 srvadmin-isvc
>> srvadmin-isvc = 5.5.0 srvadmin-jre srvadmin-jre = 5.5.0
>> srvadmin-odf srvadmin-odf = 5.5.0 srvadmin-omacore
>> srvadmin-omacore = 5.5.0 srvadmin-omauth srvadmin-omauth =
>> 5.5.0 srvadmin-omilcore srvadmin-omilcore = 5.5.0
>> srvadmin-rac3-components srvadmin-rac3-components = 5.5.0
>> srvadmin-rac4-components srvadmin-rac4-components = 5.5.0
>> srvadmin-rac5-components srvadmin-rac5-components = 5.5.0
>> srvadmin-racser srvadmin-racser = 5.5.0 srvadmin-racsvc
>> srvadmin-racsvc = 5.5.0 srvadmin-syscheck = 5.5.0 unzip
>
> Jeez!!! Thanks, I'm sorry I asked! :)
> See if I can complement my current package list with these. I'll let the
> list know if it works and post my pkg list FYI.
>
> Chris.

And don't forget the 32 vs. 64 bit issue. OMSA is 32 bit, so on 64 bit
base systems, you will need to install 32 bit versions of OMSA
dependencies.

Hey Matt -- Are we ever going to get 64 bit OMSA?

Jeff

p.s. Argh. This is my only list where default reply is to user, not
the list -- reposting...



More information about the Linux-PowerEdge mailing list