OMSA 5.5 reports incorrect megaraid_sas version

Chris Berthiaume chrisbee at u.washington.edu
Tue Feb 10 20:33:44 CST 2009


That's probably it.  I was sure I rebooted, but the logs don't lie, I 
didn't reboot.  Always check the obvious stuff first.  Thanks.

Bryan wrote:
> If you haven't rebooted, the system probably hasn't loaded the new 
> initrd and driver yet.
> 
> On Sat, Feb 7, 2009 at 5:18 PM, Chris Berthiaume 
> <chrisbee at u.washington.edu <mailto:chrisbee at u.washington.edu>> wrote:
> 
>     Hello,
> 
>     I recently updated OMSA to 5.5 on my CentOS 4.7 PE2950.  At the same
>     time I upgraded the Perc5/e Perc5/i firmware to 5.2.2-0076.  OMSA
>     produced a helpful alert about the megaraid_sas driver version being
>     below the minimum required by this new firmware, so I went and did a
>     'yum update megaraid_sas' from the Dell Linux repository.  The driver
>     package installed ok, and modinfo indicates that the latest version is
>     being used (3.21), but OMSA still reports the older 3.18 version.  As a
>     result I get a controller state of "degraded" and spurious alerts appear
>     my logs.  Is there a way to get OMSA to udpate the controller driver
>     version number?  Relevant output is below.
> 
>     Thanks,
>     Chris



More information about the Linux-PowerEdge mailing list