firmwaretool --bootstrap fails with dell_inventory_collector

Kaj Niemi kajtzu at basen.net
Tue Feb 10 13:16:41 CST 2009


Thanks, this fixes the issue :) I packaged a dell-dup with a higher  
release field that gets pulled in on installs.


On Feb 10, 2009, at 21:50, Bas Gooren wrote:

> Hi,
>
> This is a bug in the inventory collector, which I have reported to  
> dell, but they have not fixed since.
>
> You can fix it as follows:
>
> vi /usr/lib/python2.3/site-packages/dell_dup/svm.py
>
> then type:
>
> :%s/device, 10/device, 16/g
>
> ... or going to line 121 and fixing it manually.
>
> The problem is that /usr/lib/python2.3/site-packages/dell_dup/svm.py  
> assumes that another Dell tool reports some variables in decimal  
> notation, when they are in hexadecimal notation.
> The call at line 121 in the script reads "int(device, 10)", which  
> means: parse device as a decimal number. Changing it to "int(device,  
> 16)" means the script will parse it as a hexadecimal value.
>
> Regards,
>
> Bas





Kaj
-- 
Kaj J. Niemi
<kajtzu at basen.net>
FI +358 45 63 12000
KSA +966 54 52 43277




-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.us.dell.com/pipermail/linux-poweredge/attachments/20090210/d3316c31/attachment.htm 
-------------- next part --------------
A non-text attachment was scrubbed...
Name: smime.p7s
Type: application/pkcs7-signature
Size: 3833 bytes
Desc: not available
Url : http://lists.us.dell.com/pipermail/linux-poweredge/attachments/20090210/d3316c31/attachment.p7s 


More information about the Linux-PowerEdge mailing list