Multipath install of RHEL/CentOS/fedora/OEL using kickstart

christian.peper at kpn.com christian.peper at kpn.com
Wed Feb 4 04:05:34 CST 2009


No one responded to  my previous msg, so I'm simply asking again. :)
http://lists.us.dell.com/pipermail/linux-poweredge/2009-January/038488.h
tml

I hope other people have already tried to install RHEL/CentOS/Fedora/OEL
on a PowerEdge with more than one HBA. I use kickstart to do this and we
boot from SAN.

Booting the installer with the 'linux mpath' enables anaconda to use
multipath devices, i.e. /dev/mapper/* or /dev/mpath/*.

The problem I run into is that I have 5 LUNs and the boot LUN's id is 0
(zero), kickstart sees it as /dev/mapper/mpath4 as opposed to
mapper/mpath0. I was hoping Linux would enumerate the devices in order
of their LUN ids.

I am wondering if therefore the boot device mapper/mpathX will vary as X
will dependent on the number on LUNs the server sees at boot time. Has
anyone tried this or ran into a similar issue? How did you resolve it,
if you did?

Cheers.
---
Christian Peper
Linux Engineer, KPN ITNL



More information about the Linux-PowerEdge mailing list