Poweredge 1900 running Fedora 9 - Upgraded to 10 and grub locked up..

mbohne at aol.com mbohne at aol.com
Mon Feb 2 09:29:03 CST 2009


I have a 1900, RAID5 with a pair of ?QUAD core cpus. I also use LVM across this and it is both data and boot. ?All has been great until this past week and something happened (not sure yet) which caused corruption to the LVM. Sooo easy enough - boot into a live cd, lvm.. mount them and make sure they are generally ok, then unmount them and fire up fsck. Found a bunch of errors lost an inode, but still good. I ran diags and retested 4 times all options.. All came back clean. 

Now we boot a couple of times and everything is back to normal. So I figure heh.. I should go ahead push my luck and upgrade to Fedora?10 as I have had a lingering boot performance issue (takes on average 10 to 12 minutes to boot.) since I upgraded from 8 to 9. 

So did a YUM upgrade which worked fine until boot... got the lovely "GRUB" and nothing.. 

So I go googling and find a bunch of others have had this issue and you can fix it easy with supergrub - so fine download/burn/boot. 
attempt to fix. now I get can't find OS.. fine fine fine.. So I boot off the Fedora 10 DVD??and do a local upgrade and specifically tell it create/install new grub.. All goes according to plan.. No issue. 

Boot.. Grub showes older fedora 9 images and when I select it whines it can't find an image to boot. Fedora 10 not listed...

So... Any suggestions??? I can get to the drives and copy what ever I need off - I am just not very familiar with grub and getting this little tweak figured out. I am very confident this will be simple to all of you and it is a minor tweak sort of thing and BANG! back in business. 

Would also like to know if anyone else runs Fedora 9/10 on poweredge (PERC 5/i?RAID5) and are there any specialized drivers I should load for better performance or capabilities? 

I am running media servers and vmware workstation 6.5.x? leveraging hardware virtualization - mostly Windows and Ubuntu guests. 


Thanks
MB
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.us.dell.com/pipermail/linux-poweredge/attachments/20090202/3557f3a5/attachment.htm 


More information about the Linux-PowerEdge mailing list