Perc 4/Di, OMSA 5.4 on 2.6.26 not seeing controller

Brice Figureau brice+dell at daysofwonder.com
Mon Sep 29 03:37:59 CDT 2008


On Sun, 2008-09-28 at 19:40 +0200, Brice Figureau wrote:
> Hi,
> 
> On 3/09/08 21:18, Dan Reagan wrote:
> > Hi,
> > 
> > I've just installed a current Debian 'unstable' on a PE2850 and my OMSA 
> > install (download from Sara) isn't seeing the raid controller. I noticed 
> > a similar question in the archives from August 5th but can't seem to 
> > find an answer listed (if there was one).
> 
> You're not alone, I just did an upgrade of my kernel to a 2.6.26 on PE 
> 2850 with a perc 4/Di and omsa (5.3 or 5.4) can't manage the disk 
> anymore :-(
> 
> If someone have an idea on how to fix this, I'd welcome it.

I first thought I had something, but it doesn't seem that's that.
While running dataeng, my syslog was full of:

kernel: [21045.197714] Program dsm_sa_datamgr3 tried to access /dev/mem
between 591000->592000.

Which means that datamgr32 was accessing /dev/mem (why?). 2.6.26
introduced a more strict /dev/mem access.
I edited the kernel sources to allow such access as in previous kernels,
but it still doesn't work.

/dev/megadev0 is working because I can use the LSI megaRC application,
so something else is the cause of the issue.

I looked to the kernel changelog related to megaraid, but couldn't spot
anything that could have lead to this issue.

I think, it is time to switch to megactl for this server :-(

Anybody at dell can have a look to this issue? I know this is not a
supported configuration, but I'm sure there will be soon or later a RHEL
kernel which won't work, so that's just working ahead of schedule :-)
I'm ready to test whatever needs to be tested...
-- 
Brice Figureau <brice+dell at daysofwonder.com>




More information about the Linux-PowerEdge mailing list