Hard Drive firmware updates through Yum repo?

J Potter jpotter-dell at codepuppy.com
Mon Jun 30 14:44:08 CDT 2008


>> ... With a quick look at http://linux.dell.com/repo/firmware/cross-distro/RPMS/noarch/ 
>>  I see rpm versions of the SAS HDD DUPs we publish.
> Looks like the update in question (750GB SATA from firmware 3bkh to  
> 3bks) is contained in  
> ven_0x1028_dev_0x0015_subven_0x1028_subdev_0x1f03, in case anyone  
> else reads this.


Hi List --

This has come up again for us -- upgrading SATA 750GB drives from 3bkh  
to 3bks.  We're having a hard time getting the update to go through,  
though, when using "update_firmware":


> Running system inventory...
> Searching storage directory for available BIOS updates...
> ...
> Checking System BIOS for PowerEdge 6950 - 1.4.5
> 	Available: system_bios(ven_0x1028_dev_0x01ea) - 1.4.5
> 	Did not find a newer package to install that meets all installation  
> checks.
> Checking PERC 5/E Adapter Controller 1 Firmware - 5.2.1-0066
> 	Available:  
> pci_firmware(ven_0x1028_dev_0x0015_subven_0x1028_subdev_0x1f01) -  
> 5.2.1-0066
> 	Did not find a newer package to install that meets all installation  
> checks.
> Checking ST3750640NS Firmware - 3bkh
> 	Available: dell_dup_componentid_08529 - a.04
> 	Found Update: dell_dup_componentid_08529 - a.04
>
> Found firmware which needs to be updated.


This is what I see *after* running "update_firmware --yes" and  
rebooting. (The "Found Update:" bit.)  Does this mean that the 3bks  
firmware is not successfully being applied? Or that the  
dell_dup_componentid_08529 component itself isn't actaully 3bks?

Thanks!

best,
Jeff




More information about the Linux-PowerEdge mailing list