Dell SNMP .mib files in Debian

Bas Roos broos at unet.nl
Mon Jun 23 14:22:40 CDT 2008


Dear List,

Now that we are talking about Dell, Debian and MIB's, I was hoping one of 
you could help me with the following (I hope this is the right list for 
this):

I've downloaded the Dell MIBs from the Dell website (DCMIB54.exe), which 
contains a bunch of .mib files. I've extracted these in 
/usr/share/snmp/mibs on both my SNMP server and the server running my SNMP 
client, but it still doesn't seem to pick them up properly:

snmpwalk -v 2c -c public ligeti 
iso.org.dod.internet.private.enterprises.dell
iso.org.dod.internet.private.enterprises.dell: Unknown Object Identifier 
(Sub-id not found: enterprises -> dell)
snmpwalk -v 2c -c public ligeti 
iso.org.dod.internet.private.enterprises.674
SNMPv2-SMI::enterprises.674.10892.1.1.1.0 = INTEGER: 5
SNMPv2-SMI::enterprises.674.10892.1.1.2.0 = INTEGER: 8
SNMPv2-SMI::enterprises.674.10892.1.1.3.0 = INTEGER: 0
... (a lot of more lines)

All the installed mibs are being mentioned in /usr/share/snmp/mibs/.index, 
but when I strace the snmpwalk, I only see them being read once (the first 
time I've put them in the directory), and the next time(s) I run the 
snmpwalk, they aren't even touched.

It would be really nice if someone could point me in the right direction 
for this one.

Met vriendelijke groet / With kind regards,

Bas Roos
Network Engineer

UNET B.V.
Landdrostdreef 100
1314 SK Almere
T. +31 36 8 45 45 45
F. +31 36 8 45 45 98
E. broos at unet.nl



More information about the Linux-PowerEdge mailing list