SATA optical drive in T105

Luis Garrido luisgarrido at
Sun Jul 20 13:36:19 CDT 2008

On Sun, Jul 20, 2008 at 4:01 PM,  <Shyam_Iyer at> wrote:
> Can you give me the following output -
> #modinfo sata_nv

[root at cluster0 ~]# modinfo sata_nv
filename:       /lib/modules/2.6.18-92.1.6.el5/kernel/drivers/ata/sata_nv.ko
version:        3.5
license:        GPL
description:    low-level driver for NVIDIA nForce SATA controller
author:         NVIDIA
srcversion:     BA4EFA90A6CA944628A7D24
alias:          pci:v000010DEd000003F7sv*sd*bc*sc*i*
alias:          pci:v000010DEd000003F6sv*sd*bc*sc*i*
alias:          pci:v000010DEd000003E7sv*sd*bc*sc*i*
alias:          pci:v000010DEd0000037Fsv*sd*bc*sc*i*
alias:          pci:v000010DEd0000037Esv*sd*bc*sc*i*
alias:          pci:v000010DEd00000267sv*sd*bc*sc*i*
alias:          pci:v000010DEd00000266sv*sd*bc*sc*i*
alias:          pci:v000010DEd0000003Esv*sd*bc*sc*i*
alias:          pci:v000010DEd00000036sv*sd*bc*sc*i*
alias:          pci:v000010DEd00000055sv*sd*bc*sc*i*
alias:          pci:v000010DEd00000054sv*sd*bc*sc*i*
alias:          pci:v000010DEd000000EEsv*sd*bc*sc*i*
alias:          pci:v000010DEd000000E3sv*sd*bc*sc*i*
alias:          pci:v000010DEd0000008Esv*sd*bc*sc*i*
depends:        libata
vermagic:       2.6.18-92.1.6.el5 SMP mod_unload gcc-4.1
parm:           adma:Enable use of ADMA (Default: true) (bool)
parm:           swncq:Enable use of SWNCQ (Default: false) (bool)

> How much memory do you have in the system? Is it greater than 4GB? Check

I have exactly 4GB.

Booting with mem=3G did indeed work around the bug!!!

Curiously enough, I had read of this workaround and tried it for the
DVD install. mem=3G created a kernel panic about not finding the root
partition, so I desisted of exploring that avenue.

However this option works for the installer if you express it in MB
instead of GB, i.e., mem=2048M will allow you to perform a DVD
install. mem=2G won't work for the installer, but it is ok once the
system is already installed.

> Can you provide a serial capture when you get the crash on mounting the dvd.

I could probably set up a netconsole dump if it is important, let me
know, but I guess we have already pinpointed it to yet another
"sata_nv vs. 4+ GB RAM bug" instance. Is there a bug free sata_nv
driver? I tried to play around a bit with those at but they don't
seem to make any difference.

Thanks a lot, Shyam.


PS: for those curious, a more detailed description of the issue:

More information about the Linux-PowerEdge mailing list