****Re: problem install dell-repo-tools

Craig White craigwhite at azapple.com
Mon Oct 29 22:45:19 CDT 2007


On Mon, 2007-10-29 at 20:30 -0700, Craig White wrote:
> On Mon, 2007-10-29 at 22:01 -0500, Matt Domsch wrote:
> > On Mon, Oct 29, 2007 at 07:52:37PM -0700, Craig White wrote:
> > > PE 2650, CentOS-5 
> > > 
> > > # uname  -r -v -m -p -o
> > > 2.6.18-8.1.4.el5 #1 SMP Fri May 4 22:15:13 EDT 2007 i686 i686 GNU/Linux
> > > 
> > > # yum install dell-repo-tools
> > > Loading "installonlyn" plugin
> > > Loading "dellsysidplugin" plugin
> > > Setting up Install Process
> > > Setting up repositories
> > > Reading repository metadata in from local files
> > > Parsing package install arguments
> > > Resolving Dependencies
> > > --> Populating transaction set with selected packages. Please wait.
> > > ---> Package dell-repo-tools.noarch 0:1.4.5-1.el5 set to be updated
> > > --> Running transaction check
> > > --> Processing Dependency: unshield for package: dell-repo-tools
> > > --> Finished Dependency Resolution
> > > Error: Missing Dependency: unshield is needed by package dell-repo-tools
> > 
> > Grab the copy from the Fedora Core 6 archive for now.  I've asked the
> > unshield maintainer in Fedora to consider building it for EPEL as
> > well.
> ----
> easy enough I guess...
> 
> rpm -ivh \
> http://download.fedora.redhat.com/pub/fedora/linux/extras/6/SRPMS/unshield-0.5-6.fc6.src.rpm
> rpmbuild -bb unshield.spec
> rpm -ivh ../RPMS/i386/unshield-0.5-6.i386.rpm
> yum install dell-repo-tools
----
not expected...

# yum install $(inventory_firmware -b)
Loading "installonlyn" plugin
Loading "dellsysidplugin" plugin
Setting up Install Process
Setting up repositories
Reading repository metadata in from local files
Parsing package install arguments
Nothing to do

OMSA says that my PERC 3/DI is out of date...

Firmware version  2.8-0 (build 6089)
Minimum required  2.8-1 (build 6098)

shouldn't the inventory_firmware have picked that up?

Craig



More information about the Linux-PowerEdge mailing list