Expanding megaraid with LVM on bought me trouble.

Pontus Pihlgren pontus.pihlgren at farmbio.uu.se
Thu Oct 11 07:27:33 CDT 2007


Hi All.

I've got a MD1000 with one RAID-5 array, and a single disc. I wanted to
add create a RAID-5 array of the single disc as well, so I added two
more discs and did a "reconfigure" through the OMSA online interface. It
worked lika a charm, as it has done few times before. It only took some
time :)

The next step was to notify the kernel that the disk has expanded. I
followed the steps in Matt's and Michaels article here:

http://www.dell.com/content/topics/global.aspx/power/en/ps1q03_michael

So I typed in the following:

echo "scsi remove-single-device 1 2 1 0" > /proc/scsi/scsi
echo "scsi add-single-device 1 2 1 0" > /proc/scsi/scsi

Which also worked fine, almost! the disk was previously known as
"/dev/sdc" but now it is visible as "/dev/sdd".

Now when I try to mount the logical volume I get this:

mount: wrong fs type, bad option, bad superblock on /dev/Archive_VG/Archive_LV,
       or too many mounted file systems

I also get these messages in /var/log/messages:

scsi1 (1:0): rejecting I/O to dead device
EXT2-fs: unable to read superblock

Running the graphical "system-config-lvm" program that ships with centos
gives me a bunch of these messages (but still gives me sane information
about Archive_VG and Archive_LV):

Buffer I/O error on device dm-2, logical block 0

I guess LVM or device-mapper still looks for /dev/sdc. How can I get it
to recognize the changes?

Would a symlink from /dev/sdd to /dev/sdc work? And what would happen on
a reboot?

I guess this would fix itself if I restarted the machine, but I would
like to avoid that for as long as possible.

Thank You,
Pontus.



More information about the Linux-PowerEdge mailing list